程序師世界是廣大編程愛好者互助、分享、學習的平台,程序師世界有你更精彩!
首頁
編程語言
C語言|JAVA編程
Python編程
網頁編程
ASP編程|PHP編程
JSP編程
數據庫知識
MYSQL數據庫|SqlServer數據庫
Oracle數據庫|DB2數據庫
 程式師世界 >> 編程語言 >> C語言 >> C++ >> C++入門知識 >> uva 644

uva 644

編輯:C++入門知識

An encoding of a set of symbols is said to be immediately decodable if no code for one symbol is the prefix of a code for another symbol. We will assume for this problem that all codes are in binary, that no two codes within a set of codes are the same, that each code has at least one bit and no more than ten bits, and that each set has at least two codes and no more than eight.


Examples: Assume an alphabet that has symbols {A, B, C, D}


The following code is immediately decodable:


A:01 B:10 C:0010 D:0000


but this one is not:


A:01 B:10 C:010 D:0000 (Note that A is a prefix of C)

Input
Write a program that accepts as input a series of groups of records from a data file. Each record in a group contains a collection of zeroes and ones representing a binary code for a different symbol. Each group is followed by a single separator record containing a single 9; the separator records are not part of the group. Each group is independent of other groups; the codes in one group are not related to codes in any other group (that is, each group is to be processed independently).
Output
For each group, your program should determine whether the codes in that group are immediately decodable, and should print a single output line giving the group number and stating whether the group is, or is not, immediately decodable.

The Sample Input describes the examples above.

Sample Input
01
10
0010
0000
9
01
10
010
0000
9
Sample Output
Set 1 is immediately decodable
Set 2 is not immediately decodable


 

#include <stdio.h>
#include <string.h>

char str[100][100];
int permix(int j, int k)         //檢查一個串是否為另一個串的前綴
{
     int n, m, index;
     n = strlen(str[j]);
     m = strlen(str[k]);
     if(n > m)
     {
          n = m;
     }
     for(index = 0; index < n; index++)
     {
          if(str[j][index] != str[k][index])
          {
               return 0;
          }
     }
     return 1;
}
int main()
{
     int i,count,flag,j;
     i = 0;
     count = 0;               //測試組數
     flag = 0;               //標記
     while(gets(str[i]))
     {
          if(str[i][0] == '9')          //遇到單個字符9時輸出
          {
               count++;              
               if(flag)
               {
                    printf("Set %d is not immediately decodable\n", count);
               }
               else
               {
                    printf("Set %d is immediately decodable\n", count);
               }
               flag = 0;
               i = 0;
              continue;     //一定加上這句不然錯了
          }
          for(j = 0; j < i; j++)
          {
               if(permix(i,j))
               {
                    flag = 1;
               }
          }
          i++;
     }
     return 0;
}

 

  1. 上一頁:
  2. 下一頁:
Copyright © 程式師世界 All Rights Reserved