程序師世界是廣大編程愛好者互助、分享、學習的平台,程序師世界有你更精彩!
首頁
編程語言
C語言|JAVA編程
Python編程
網頁編程
ASP編程|PHP編程
JSP編程
數據庫知識
MYSQL數據庫|SqlServer數據庫
Oracle數據庫|DB2數據庫
 程式師世界 >> 編程語言 >> C語言 >> C++ >> C++入門知識 >> HDU3853:LOOPS(概率DP)

HDU3853:LOOPS(概率DP)

編輯:C++入門知識

 Problem Description
Akemi Homura is a Mahou Shoujo (Puella Magi/Magical Girl).

Homura wants to help her friend Madoka save the world. But because of the plot of the Boss Incubator, she is trapped in a labyrinth called LOOPS.

 

The planform of the LOOPS is a rectangle of R*C grids. There is a portal in each grid except the exit grid. It costs Homura 2 magic power to use a portal once. The portal in a grid G(r, c) will send Homura to the grid below G (grid(r+1, c)), the grid on the right of G (grid(r, c+1)), or even G itself at respective probability (How evil the Boss Incubator is)!
At the beginning Homura is in the top left corner of the LOOPS ((1, 1)), and the exit of the labyrinth is in the bottom right corner ((R, C)). Given the probability of transmissions of each portal, your task is help poor Homura calculate the EXPECT magic power she need to escape from the LOOPS.

 

 

 


Input
The first line contains two integers R and C (2 <= R, C <= 1000).

The following R lines, each contains C*3 real numbers, at 2 decimal places. Every three numbers make a group. The first, second and third number of the cth group of line r represent the probability of transportation to grid (r, c), grid (r, c+1), grid (r+1, c) of the portal in grid (r, c) respectively. Two groups of numbers are separated by 4 spaces.

It is ensured that the sum of three numbers in each group is 1, and the second numbers of the rightmost groups are 0 (as there are no grids on the right of them) while the third numbers of the downmost groups are 0 (as there are no grids below them).

You may ignore the last three numbers of the input data. They are printed just for looking neat.

The answer is ensured no greater than 1000000.

Terminal at EOF

 

 


Output
A real number at 3 decimal places (round to), representing the expect magic power Homura need to escape from the LOOPS.


 


Sample Input
2 2
0.00 0.50 0.50    0.50 0.00 0.50
0.50 0.50 0.00    1.00 0.00 0.00


Sample Output
6.000

題意:迷宮是一個R*C的布局,每個格子中給出停留在原地,往右走一個,往下走一格的概率,起點在(1,1),終點在(R,C),每走一格消耗兩點能量,求出最後所需要的能量期望

思路:期望DP的入門,dp[i][j]記錄從i,j出發到終點所需期望,map[i][j][k],記錄每格三種狀況的概率,按照數學期望公式去計算即可

 

 

#include <stdio.h>
#include <string.h>
#include <math.h>
#include <algorithm>
using namespace std;

double dp[1005][1005],map[1005][1005][3];

int main()
{
    int r,c,i,j,k;
    while(~scanf("%d%d",&r,&c))
    {
        memset(dp,0,sizeof(dp));
        for(i = 1; i<=r; i++)
            for(j = 1; j<=c; j++)
                for(k = 0; k<3; k++)
                    scanf("%lf",&map[i][j][k]);
        for(i = r; i>0; i--)
        {
            for(j = c; j>0; j--)
            {
                if(i == r && j == c)//到達終點了
                    continue;
                if(fabs(1-map[i][j][0])<1e-7)//停留原地的概率為1
                    continue;
                dp[i][j] = (map[i][j][1]*dp[i][j+1]+map[i][j][2]*dp[i+1][j]+2)/(1-map[i][j][0]);//+2是到下一格消耗的能量
            }
        }
        printf("%.3lf\n",dp[1][1]);
    }

    return 0;
}

 

  1. 上一頁:
  2. 下一頁:
Copyright © 程式師世界 All Rights Reserved