程序師世界是廣大編程愛好者互助、分享、學習的平台,程序師世界有你更精彩!
首頁
編程語言
C語言|JAVA編程
Python編程
網頁編程
ASP編程|PHP編程
JSP編程
數據庫知識
MYSQL數據庫|SqlServer數據庫
Oracle數據庫|DB2數據庫
 程式師世界 >> 編程語言 >> C語言 >> C++ >> C++入門知識 >> hdu2096 Collecting Bugs

hdu2096 Collecting Bugs

編輯:C++入門知識

Collecting Bugs
Time Limit: 10000MS   Memory Limit: 64000K
Total Submissions: 1730   Accepted: 794
Case Time Limit: 2000MS   Special Judge

Description

Ivan is fond of collecting. Unlike other people who collect post stamps, coins or other material stuff, he collects software bugs. When Ivan gets a new program, he classifies all possible bugs into n categories. Each day he discovers exactly one bug in the program and adds information about it and its category into a spreadsheet. When he finds bugs in all bug categories, he calls the program disgusting, publishes this spreadsheet on his home page, and forgets completely about the program.
Two companies, Macrosoft and Microhard are in tight competition. Microhard wants to decrease sales of one Macrosoft program. They hire Ivan to prove that the program in question is disgusting. However, Ivan has a complicated problem. This new program has s subcomponents, and finding bugs of all types in each subcomponent would take too long before the target could be reached. So Ivan and Microhard agreed to use a simpler criteria --- Ivan should find at least one bug in each subsystem and at least one bug of each category.
Macrosoft knows about these plans and it wants to estimate the time that is required for Ivan to call its program disgusting. It's important because the company releases a new version soon, so it can correct its plans and release it quicker. Nobody would be interested in Ivan's opinion about the reliability of the obsolete version.
A bug found in the program can be of any category with equal probability. Similarly, the bug can be found in any given subsystem with equal probability. Any particular bug cannot belong to two different categories or happen simultaneously in two different subsystems. The number of bugs in the program is almost infinite, so the probability of finding a new bug of some category in some subsystem does not reduce after finding any number of bugs of that category in that subsystem.
Find an average time (in days of Ivan's work) required to name the program disgusting.
Input

Input file contains two integer numbers, n and s (0 < n, s <= 1 000).
Output

Output the expectation of the Ivan's working days needed to call the program disgusting, accurate to 4 digits after the decimal point.
Sample Input

1 2Sample Output

3.0000Source

Northeastern Europe 2004, Northern Subregion
水題dp,不解釋 dp[i][j],已經找了i個bug,和j個服務器還要用的天數期望值
dp[i][j]可以轉化成dp[i][j],dp[i+1][j],dp[i][j+1],dp[i+1][j+1]這四種狀態,其中的這樣,我們就可以得到dp[i][j]=p1*dp[i][j]+p2*dp[i][j+1]+p3*dp[i+1][j+1];+p4*dp[i+1][j+1];

#include <iostream>   
#include <string.h>   
#include <stdio.h>   
using namespace std;  
#define MAXN 1005   
double dp[MAXN][MAXN];  
int main()  
{  
    int n,s,i,j;  
    while(scanf("%d%d",&n,&s)!=EOF)  
    {  
        dp[n][s]=0;  
        for(i=n;i>=0;i--)  
            for(j=s;j>=0;j--)  
            {  
                if(i==n&&j==s)  
                continue;  
                dp[i][j]=0;  
                dp[i][j]+=dp[i+1][j]*(n-i)*j*1.0+n*s+dp[i][j+1]*(s-j)*i*1.0+dp[i+1][j+1]*(n-i)*(s-j)*1.0;  
                dp[i][j]/=(n*s*1.0-1.0*i*j);  
            }  
            printf("%.4f\n",dp[0][0]);  
    }  
    return 0;  
}  

#include <iostream>
#include <string.h>
#include <stdio.h>
using namespace std;
#define MAXN 1005
double dp[MAXN][MAXN];
int main()
{
    int n,s,i,j;
    while(scanf("%d%d",&n,&s)!=EOF)
    {
        dp[n][s]=0;
        for(i=n;i>=0;i--)
            for(j=s;j>=0;j--)
            {
                if(i==n&&j==s)
                continue;
                dp[i][j]=0;
                dp[i][j]+=dp[i+1][j]*(n-i)*j*1.0+n*s+dp[i][j+1]*(s-j)*i*1.0+dp[i+1][j+1]*(n-i)*(s-j)*1.0;
                dp[i][j]/=(n*s*1.0-1.0*i*j);
            }
            printf("%.4f\n",dp[0][0]);
    }
    return 0;
}


 

  1. 上一頁:
  2. 下一頁:
Copyright © 程式師世界 All Rights Reserved