程序師世界是廣大編程愛好者互助、分享、學習的平台,程序師世界有你更精彩!
首頁
編程語言
C語言|JAVA編程
Python編程
網頁編程
ASP編程|PHP編程
JSP編程
數據庫知識
MYSQL數據庫|SqlServer數據庫
Oracle數據庫|DB2數據庫
 程式師世界 >> 編程語言 >> C語言 >> C++ >> C++入門知識 >> poj 3009 Curling 2.0 DFS

poj 3009 Curling 2.0 DFS

編輯:C++入門知識

Description On Planet MM-21, after their Olympic games this year, curling is getting popular. But the rules are somewhat different from ours. The game is played on an ice game board on which a square mesh is marked. They use only a single stone. The purpose of the game is to lead the stone from the start to the goal with the minimum number of moves. Fig. 1 shows an example of a game board. Some squares may be occupied with blocks. There are two special squares namely the start and the goal, which are not occupied with blocks. (These two squares are distinct.) Once the stone begins to move, it will proceed until it hits a block. In order to bring the stone to the goal, you may have to stop the stone by hitting it against a block, and throw again.   Fig. 1: Example of board (S: start, G: goal) The movement of the stone obeys the following rules: At the beginning, the stone stands still at the start square. The movements of the stone are restricted to x and y directions. Diagonal moves are prohibited. When the stone stands still, you can make it moving by throwing it. You may throw it to any direction unless it is blocked immediately(Fig. 2(a)). Once thrown, the stone keeps moving to the same direction until one of the following occurs: The stone hits a block (Fig. 2(b), (c)). The stone stops at the square next to the block it hit. The block disappears. The stone gets out of the board. The game ends in failure. The stone reaches the goal square. The stone stops there and the game ends in success. You cannot throw the stone more than 10 times in a game. If the stone does not reach the goal in 10 moves, the game ends in failure.   Fig. 2: Stone movements Under the rules, we would like to know whether the stone at the start can reach the goal and, if yes, the minimum number of moves required. With the initial configuration shown in Fig. 1, 4 moves are required to bring the stone from the start to the goal. The route is shown in Fig. 3(a). Notice when the stone reaches the goal, the board configuration has changed as in Fig. 3(b).   Fig. 3: The solution for Fig. D-1 and the final board configuration Input The input is a sequence of datasets. The end of the input is indicated by a line containing two zeros separated by a space. The number of datasets never exceeds 100. Each dataset is formatted as follows. the width(=w) and the height(=h) of the board  First row of the board  ...  h-th row of the board The width and the height of the board satisfy: 2 <= w <= 20, 1 <= h <= 20. Each line consists of w decimal numbers delimited by a space. The number describes the status of the corresponding square. 0 vacant square 1 block 2 start position 3 goal position The dataset for Fig. D-1 is as follows: 6 6  1 0 0 2 1 0  1 1 0 0 0 0  0 0 0 0 0 3  0 0 0 0 0 0  1 0 0 0 0 1  0 1 1 1 1 1 Output For each dataset, print a line having a decimal integer indicating the minimum number of moves along a route from the start to the goal. If there are no such routes, print -1 instead. Each line should not have any character other than this number. Sample Input 2 1 3 2 6 6 1 0 0 2 1 0 1 1 0 0 0 0 0 0 0 0 0 3 0 0 0 0 0 0 1 0 0 0 0 1 0 1 1 1 1 1 6 1 1 1 2 1 1 3 6 1 1 0 2 1 1 3 12 1 2 0 1 1 1 1 1 1 1 1 1 3 13 1 2 0 1 1 1 1 1 1 1 1 1 1 3 0 0 Sample Output 1 4 -1 4 10 -1 思路:DFS沿著一個方向一直走直到遇到障礙,注意一下一些特殊輸入。

#include <iostream>
#include <cstdio>
#include <fstream>
using namespace std;
const int maxn=25;
int maze[maxn][maxn];
int dir[4][2]={0,1,0,-1,1,0,-1,0}; 
int ans,N,M,sx,sy;

void dfs(int x,int y,int step){
	if(step>10)return ;
	
	for(int i=0;i<4;i++){
		int nx=x+dir[i][0],ny=y+dir[i][1];
		if(nx<0||nx>=N||ny<0||ny>=M) continue;
		if(maze[nx][ny]==1)continue; //旁邊是障礙,無法走。 
		
		while(maze[nx][ny]!=1)
		{
			if(maze[nx][ny]==3) //一定要先判斷,若終點就在旁邊。 
			{
				if(ans>step){
					ans=step;
					return ;
				}
			}
			nx+=dir[i][0];ny+=dir[i][1];
			if(nx<0||nx>=N||ny<0||ny>=M) break;
		}
		if(nx>=0 && nx<N && ny>=0 &&ny<M){
			maze[nx][ny]=0;
			dfs(nx-dir[i][0],ny-dir[i][1],step+1);
			maze[nx][ny]=1;
		}
	}
}

int main(){
	//ifstream fin;
	//fin.open("input.txt");
	
	while(cin>>M>>N){
		if(N+M==0)break;
		for(int i=0;i<N;i++)
			for(int j=0;j<M;j++){
				cin>>maze[i][j];
				if(maze[i][j]==2){
					sx=i;sy=j;
				}
			}
		ans=999999;
		dfs(sx,sy,1);
		if(ans>10) cout<<-1<<endl;
		else cout<<ans<<endl;	
	}
	return 0;
}

 


  1. 上一頁:
  2. 下一頁:
Copyright © 程式師世界 All Rights Reserved