程序師世界是廣大編程愛好者互助、分享、學習的平台,程序師世界有你更精彩!
首頁
編程語言
C語言|JAVA編程
Python編程
網頁編程
ASP編程|PHP編程
JSP編程
數據庫知識
MYSQL數據庫|SqlServer數據庫
Oracle數據庫|DB2數據庫
 程式師世界 >> 編程語言 >> C語言 >> C++ >> C++入門知識 >> hdu4709求三角形面積

hdu4709求三角形面積

編輯:C++入門知識

Herding Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 702    Accepted Submission(s): 174     Problem Description Little John is herding his father's cattles. As a lazy boy, he cannot tolerate chasing the cattles all the time to avoid unnecessary omission. Luckily, he notice that there were N trees in the meadow numbered from 1 to N, and calculated their cartesian coordinates (Xi, Yi). To herding his cattles safely, the easiest way is to connect some of the trees (with different numbers, of course) with fences, and the close region they formed would be herding area. Little John wants the area of this region to be as small as possible, and it could not be zero, of course.     Input The first line contains the number of test cases T( T<=25 ). Following lines are the scenarios of each test case. The first line of each test case contains one integer N( 1<=N<=100 ). The following N lines describe the coordinates of the trees. Each of these lines will contain two float numbers Xi and Yi( -1000<=Xi, Yi<=1000 ) representing the coordinates of the corresponding tree. The coordinates of the trees will not coincide with each other.     Output For each test case, please output one number rounded to 2 digits after the decimal point representing the area of the smallest region. Or output "Impossible"(without quotations), if it do not exists such a region.     Sample Input 1 4 -1.00 0.00 0.00 -3.00 2.00 0.00 2.00 2.00     Sample Output 2.00     Source 2013 ACM/ICPC Asia Regional Online —— Warmup   分析:求最小面積就是求所有點構成的所有三角形的最小面積,但是要注意選擇構成三角形的三個點不能在一條線上,橫,豎,斜不能在一條線上

 #include<iostream>  
#include<cstdio>  
#include<cstdlib>  
#include<cstring>  
#include<string>  
#include<queue>  
#include<algorithm>  
#include<map>  
#include<cmath>  
#include<iomanip>  
#define INF 99999999  
using namespace std;  
  
const int MAX=100+10;  
double s[MAX][2];  
  
double calculate(int i,int j,int k){  
    return fabs((s[j][0]-s[i][0])*(s[k][1]-s[i][1])-(s[k][0]-s[i][0])*(s[j][1]-s[i][1]))/2;  
}  
  
int main(){  
    int t,n;  
    scanf("%d",&t);  
    while(t--){  
        scanf("%d",&n);  
        for(int i=0;i<n;++i)scanf("%lf%lf",&s[i][0],&s[i][1]);  
        double sum=INF*1.0;  
        for(int i=0;i<n;++i){  
            for(int j=i+1;j<n;++j){  
                for(int k=j+1;k<n;++k){  
                    if(s[i][1] == s[j][1] && s[j][1] == s[k][1])continue;  
                    if((s[j][1]-s[i][1])/(s[j][0]-s[i][0]) == (s[k][1]-s[j][1])/(s[k][0]-s[j][0]))continue;  
                    sum=min(sum,calculate(i,j,k));  
                }  
            }  
        }  
        if(sum == INF*1.0)printf("Impossible\n");  
        else printf("%.2lf\n",sum);  
    }  
    return 0;  
}  

 


  1. 上一頁:
  2. 下一頁:
Copyright © 程式師世界 All Rights Reserved