程序師世界是廣大編程愛好者互助、分享、學習的平台,程序師世界有你更精彩!
首頁
編程語言
C語言|JAVA編程
Python編程
網頁編程
ASP編程|PHP編程
JSP編程
數據庫知識
MYSQL數據庫|SqlServer數據庫
Oracle數據庫|DB2數據庫
 程式師世界 >> 編程語言 >> C語言 >> C++ >> C++入門知識 >> hdu4708 Rotation Lock Puzzle

hdu4708 Rotation Lock Puzzle

編輯:C++入門知識

Rotation Lock Puzzle Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 654 Accepted Submission(s): 190     Problem Description Alice was felling into a cave. She found a strange door with a number square matrix. These numbers can be rotated around the center clockwise or counterclockwise. A fairy came and told her how to solve this puzzle lock: “When the sum of main diagonal and anti-diagonal is maximum, the door is open.”. Here, main diagonal is the diagonal runs from the top left corner to the bottom right corner, and anti-diagonal runs from the top right to the bottom left corner. The size of square matrix is always odd.         This sample is a square matrix with 5*5. The numbers with vertical shadow can be rotated around center ‘3’, the numbers with horizontal shadow is another queue. Alice found that if she rotated vertical shadow number with one step, the sum of two diagonals is maximum value of 72 (the center number is counted only once).   Input Multi cases is included in the input file. The first line of each case is the size of matrix n, n is a odd number and 3<=n<=9.There are n lines followed, each line contain n integers. It is end of input when n is 0 .   Output For each test case, output the maximum sum of two diagonals and minimum steps to reach this target in one line.   Sample Input 5 9 3 2 5 9 7 4 7 5 4 6 9 3 9 3 5 2 8 7 2 9 9 4 1 9 0   Sample Output 72 1   Source 2013 ACM/ICPC Asia Regional Online —— Warmup   Recommend liuyiding 很簡單的模擬!

#include <iostream>  
#include <stdio.h>  
#include <math.h>  
#include <string.h>  
using namespace std;  
int map[12][12];  
int main()  
{  
  int i,j,n,maxx,maxstep,anss,ans;  
  while(scanf("%d",&n)!=EOF&&n)  
  {  
    for(i=0;i<n;i++)  
        for(j=0;j<n;j++)  
        scanf("%d",&map[i][j]);  
    int n2=n/2,temp;  
    ans=map[n2][n2];anss=0;  
    for(i=0;i<n2;i++)  
    {  
        int a=0;  int i2=n-i*2;  
        maxx=map[i][i+a]+map[i+a][n-i-1]+map[n-i-a-1][i]+map[n-i-1][n-i-1-a];  
        maxstep=min(a,i2-1-a);  
        for(a=1;a<i2;a++)  
        {  
            temp=map[i][i+a]+map[i+a][n-i-1]+map[n-i-a-1][i]+map[n-i-1][n-i-1-a];  
            if(temp>maxx)  
            {  
                maxx=temp;  
                maxstep=min(a,i2-1-a);  
            }  
            else if(temp==maxx)  
            {  
                maxstep=min(maxstep,min(a,i2-1-a));  
            }  
        }  
        ans+=maxx;  
        anss+=maxstep;  
    }  
    printf("%d %d\n",ans,anss);  
  }  
  return 0;  
}  

 


  1. 上一頁:
  2. 下一頁:
Copyright © 程式師世界 All Rights Reserved