程序師世界是廣大編程愛好者互助、分享、學習的平台,程序師世界有你更精彩!
首頁
編程語言
C語言|JAVA編程
Python編程
網頁編程
ASP編程|PHP編程
JSP編程
數據庫知識
MYSQL數據庫|SqlServer數據庫
Oracle數據庫|DB2數據庫
 程式師世界 >> 編程語言 >> C語言 >> C++ >> C++入門知識 >> HDU4707:Pet(DFS)

HDU4707:Pet(DFS)

編輯:C++入門知識

Problem Description One day, Lin Ji wake up in the morning and found that his pethamster escaped. He searched in the room but didn’t find the hamster. He tried to use some cheese to trap the hamster. He put the cheese trap in his room and waited for three days. Nothing but cockroaches was caught. He got the map of the school and foundthat there is no cyclic path and every location in the school can be reached from his room. The trap’s manual mention that the pet will always come back if it still in somewhere nearer than distance D. Your task is to help Lin Ji to find out how many possible locations the hamster may found given the map of the school. Assume that the hamster is still hiding in somewhere in the school and distance between each adjacent locations is always one distance unit.     Input The input contains multiple test cases. Thefirst line is a positive integer T (0<T<=10), the number of test cases. For each test cases, the first line has two positive integer N (0<N<=100000) and D(0<D<N), separated by a single space. N is the number of locations in the school and D is the affective distance of the trap. The following N-1lines descripts the map, each has two integer x and y(0<=x,y<N), separated by a single space, meaning that x and y is adjacent in the map. Lin Ji’s room is always at location 0.     Output For each test case, outputin a single line the number of possible locations in the school the hamster may be found.     Sample Input 1 10 2 0 1 0 2 0 3 1 4 1 5 2 6 3 7 4 8 6 9     Sample Output 2       題意:所有房子組成一顆樹,求出離根節點0的距離大於d的節點數目   思路:建樹深搜        

#include <stdio.h>  
#include <string.h>  
#include <algorithm>  
using namespace std;  
  
struct node  
{  
    int next,to;  
    int step;  
} a[100005];  
  
int head[100005];  
int n,d,len,ans;  
  
void add(int x,int y)  
{  
    a[len].to = y;  
    a[len].next = head[x];  
    head[x] = len++;  
}  
  
void dfs(int x,int step)  
{  
    int i,j,k;  
    if(-1 == head[x])  
        return ;  
    for(i = head[x]; i!=-1; i = a[i].next)  
    {  
        k = a[i].to;  
        a[i].step = step+1;  
        if(a[i].step>d)  
            ans++;  
        dfs(k,a[i].step);  
    }  
}  
  
int main()  
{  
    int T,i,j,x,y;  
    scanf("%d",&T);  
    while(T--)  
    {  
        memset(head,-1,sizeof(head));  
        memset(a,0,sizeof(a));  
        scanf("%d%d",&n,&d);  
        len = 0;  
        for(i = 1; i<n; i++)  
        {  
            scanf("%d%d",&x,&y);  
            add(x,y);  
        }  
        ans = 0;  
        dfs(0,0);  
        printf("%d\n",ans);  
    }  
  
    return 0;  
}  

 


  1. 上一頁:
  2. 下一頁:
Copyright © 程式師世界 All Rights Reserved