程序師世界是廣大編程愛好者互助、分享、學習的平台,程序師世界有你更精彩!
首頁
編程語言
C語言|JAVA編程
Python編程
網頁編程
ASP編程|PHP編程
JSP編程
數據庫知識
MYSQL數據庫|SqlServer數據庫
Oracle數據庫|DB2數據庫
 程式師世界 >> 編程語言 >> C語言 >> C++ >> C++入門知識 >> ACM學習-POJ-1004-Financial Management

ACM學習-POJ-1004-Financial Management

編輯:C++入門知識

 菜鳥學習ACM,紀錄自己成長過程中的點滴。 學習的路上,與君共勉。 ACM學習-POJ-1003-Financial Management   Financial Management Time Limit: 1000MS Memory Limit: 10000K Total Submissions: 109412 Accepted: 51958   Description Larry graduated this year and finally has a job. He's making a lot of money, but somehow never seems to have enough. Larry has decided that he needs to grab hold of his financial portfolio and solve his financing problems. The first step is to figure out what's been going on with his money. Larry has his bank account statements and wants to see how much money he has. Help Larry by writing a program to take his closing balance from each of the past twelve months and calculate his average account balance. Input The input will be twelve lines. Each line will contain the closing balance of his bank account for a particular month. Each number will be positive and displayed to the penny. No dollar sign will be included. Output The output will be a single number, the average (mean) of the closing balances for the twelve months. It will be rounded to the nearest penny, preceded immediately by a dollar sign, and followed by the end-of-line. There will be no other spaces or characters in the output. Sample Input 100.00 489.12 12454.12 1234.10 823.05 109.20 5.27 1542.25 839.18 83.99 1295.01 1.75 Sample Output $1581.42 Source Mid-Atlantic 2001   問題要求:  求12個數的平均數。 問題分析: .....看到這題目,頓時嚇尿了。   我做題目都是看AC率下手的。  從50%開始逐步練習。  不過這道AC率48%的題目,確實水的可以了。  估計大牛們都不屑做這個吧。   好吧,這道也沒什麼特別需要注意的。 就是類型轉換的時候注意下就好了。  直接上代碼吧。    

#include <stdio.h>  
  
int main()  
{  
    int n = 0;  
    double sum_ = 0.0;  
    double each_month;  
      
    while (~scanf("%lf", &each_month) && n < 12)  
    {  
        sum_ += each_month;  
        n++;  
        if (n==12)  
        {  
            printf("$%.2lf\n", sum_/(double)n);  
            break;  
        }  
    }  
    return 0;  
}  

 

 

  1. 上一頁:
  2. 下一頁:
Copyright © 程式師世界 All Rights Reserved