程序師世界是廣大編程愛好者互助、分享、學習的平台,程序師世界有你更精彩!
首頁
編程語言
C語言|JAVA編程
Python編程
網頁編程
ASP編程|PHP編程
JSP編程
數據庫知識
MYSQL數據庫|SqlServer數據庫
Oracle數據庫|DB2數據庫
 程式師世界 >> 編程語言 >> C語言 >> C++ >> 關於C++ >> HDOJ(HDU) 1985 Conversions(匯率轉換)

HDOJ(HDU) 1985 Conversions(匯率轉換)

編輯:關於C++

Problem Description
Conversion between the metric and English measurement systems is relatively simple. Often, it involves either multiplying or dividing by a constant. You must write a program that converts between the following units:
\

Input
The first line of input contains a single integer N, (1 ≤ N ≤ 1000) which is the number of datasets that follow.
Each dataset consists of a single line of input containing a floating point (double precision) number, a space and the unit specification for the measurement to be converted. The unit specification is one of kg, lb, l, or g referring to kilograms, pounds, liters and gallons respectively.

Output
For each dataset, you should generate one line of output with the following values: The dataset number as a decimal integer (start counting at one), a space, and the appropriately converted value rounded to 4 decimal places, a space and the unit specification for the converted value.

Sample Input
5
1 kg
2 l
7 lb
3.5 g
0 l

Sample Output
1 2.2046 lb
2 0.5284 g
3 3.1752 kg
4 13.2489 l
5 0.0000 g

題目很簡單,就是給出了匯率,讓你轉換!!!
水題!

import java.util.Scanner;

public class Main{
    public static void main(String[] args) {
        Scanner sc = new Scanner(System.in);
        String[] str1 = {"kg","l","lb","g"};
        String[] str2 = {"lb","g","kg","l"};
        double[]  d = {2.2046,0.2642,0.4536,3.7854};
        int time = 1;
        int t = sc.nextInt();
        while(t-->0){
            int k=0;
            double n = sc.nextDouble();
            String s = sc.next();
            for(int i=0;i
  1. 上一頁:
  2. 下一頁:
Copyright © 程式師世界 All Rights Reserved