程序師世界是廣大編程愛好者互助、分享、學習的平台,程序師世界有你更精彩!
首頁
編程語言
C語言|JAVA編程
Python編程
網頁編程
ASP編程|PHP編程
JSP編程
數據庫知識
MYSQL數據庫|SqlServer數據庫
Oracle數據庫|DB2數據庫
 程式師世界 >> 編程語言 >> C語言 >> C++ >> 關於C++ >> hdu1022(Train Problem I)

hdu1022(Train Problem I)

編輯:關於C++

點擊打開鏈接

 

Problem Description

As the new term comes, the Ignatius Train Station is very busy nowadays. A lot of student want to get back to school by train(because the trains in the Ignatius Train Station is the fastest all over the world ^v^). But here comes a problem, there is only one railway where all the trains stop. So all the trains come in from one side and get out from the other side. For this problem, if train A gets into the railway first, and then train B gets into the railway before train A leaves, train A can't leave until train B leaves. The pictures below figure out the problem. Now the problem for you is, there are at most 9 trains in the station, all the trains has an ID(numbered from 1 to n), the trains get into the railway in an order O1, your task is to determine whether the trains can get out in an order O2.
\\\

Input

The input contains several test cases. Each test case consists of an integer, the number of trains, and two strings, the order of the trains come in:O1, and the order of the trains leave:O2. The input is terminated by the end of file. More details in the Sample Input.

Output

The output contains a string No. if you can't exchange O2 to O1, or you should output a line contains Yes., and then output your way in exchanging the order(you should output in for a train getting into the railway, and out for a train getting out of the railway). Print a line contains FINISH after each test case. More details in the Sample Output.

Sample Input

3 123 321
3 123 312

Sample Output

Yes.
in
in
in
out
out
out
FINISH
No.
FINISH

 

題意:就是說給一個火車進站的序列,然後再給你一個火車出站的序列,而火車站最多能停n列火車,問是否能按所給的序列號讓火車出站。

注:並不是非要讓所有進站的火車全部進來才能出站,只是如果火車站進了多列火車,後進來的必須先出,這就是棧:後進先出

 

 

package stack;

import java.util.Scanner;

public class P1022 {
	static int n;
	public static void main(String[] args) {
		Scanner sc=new Scanner(System.in);
		char[] in,out;
		String s;
		String[] path;
		int count,j;
		while(sc.hasNext()){
			n=sc.nextInt();
			s=sc.next();
			in=s.toCharArray();
			s=sc.next();
			out=s.toCharArray();
			path=new String[n*2];
			count=0;j=0;
			TrainStack trainStack=new TrainStack(n);
			for(int i=0;i

 

 

 

 

 

  1. 上一頁:
  2. 下一頁:
Copyright © 程式師世界 All Rights Reserved