程序師世界是廣大編程愛好者互助、分享、學習的平台,程序師世界有你更精彩!
首頁
編程語言
C語言|JAVA編程
Python編程
網頁編程
ASP編程|PHP編程
JSP編程
數據庫知識
MYSQL數據庫|SqlServer數據庫
Oracle數據庫|DB2數據庫
 程式師世界 >> 編程語言 >> C語言 >> 關於C語言 >> HDU2602 (0-1背包問題),hdu26020-1背包問題

HDU2602 (0-1背包問題),hdu26020-1背包問題

編輯:關於C語言

HDU2602 (0-1背包問題),hdu26020-1背包問題


  N - 01背包 Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u  

Description

Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave … 
The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the maximum of the total value the bone collector can get ? 
 

Input

The first line contain a integer T , the number of cases. 
Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.  

Output

One integer per line representing the maximum of the total value (this number will be less than 2 31).  

Sample Input

1 5 10 1 2 3 4 5 5 4 3 2 1  

Sample Output

14     題解:0-1背包問題,dp[i][j]表示i個物品最大價值j
#include<iostream>
#include<cstring>
#include<cstdio>
using namespace std;
int dp[1000][1000];
int a[1000],b[1000];
int main()
{
    int t,n,v;
    cin>>t;
    while(t--)
    {
        cin>>n>>v;
        for(int i=1;i<=n;i++)
            scanf("%d",&a[i]);
        for(int i=1;i<=n;i++)
            scanf("%d",&b[i]);
        memset(dp,0,sizeof(dp));
         for(int i=1;i<=n;i++)
        {
            for(int j=0;j<=v;j++)
            {
                dp[i][j]=(i==1?0:dp[i-1][j]);
                if(j>=b[i])
                    dp[i][j]=max(dp[i-1][j],dp[i-1][j-b[i]]+a[i]);
            }
        }
        printf("%d\n",dp[n][v]);
    }
    return 0;
}

 

  1. 上一頁:
  2. 下一頁:
Copyright © 程式師世界 All Rights Reserved