程序師世界是廣大編程愛好者互助、分享、學習的平台,程序師世界有你更精彩!
首頁
編程語言
C語言|JAVA編程
Python編程
網頁編程
ASP編程|PHP編程
JSP編程
數據庫知識
MYSQL數據庫|SqlServer數據庫
Oracle數據庫|DB2數據庫
 程式師世界 >> 編程語言 >> C語言 >> 關於C語言 >> Alfredo's Pizza Restaurant

Alfredo's Pizza Restaurant

編輯:關於C語言

Description

Traditionally after the Local Contest, judges and contestants go to their favourite restaurant, Alfredos Pizza Restaurant. The contestants are really hungry after trying hard for five hours. To get their pizza as quickly as possible, they just decided to order one big pizza for all instead of several small ones. They wonder whether it is possible to put the big rectangular pizza on the surface of the round table such that it does not overhang the border of the table. Write a program that helps them!

Input

The input file contains several test cases. Each test case starts with an integer number r, the radius of the surface of the round table the contestants are sitting at. Input is terminated by r=0. Otherwise, 1 ≤ r ≤ 1000. Then follow 2 integer numbers w and l specifying the width and the length of the pizza, 1 ≤ w ≤ l ≤ 1000.

Output

Output for each test case whether the ordered pizza will fit on the table or not. Adhere to the format shown in the sample output. A pizza which just touches the border of the table without intersecting it is considered fitting on the table, see example 3 for clarification.

Sample Input

38 40 60

35 20 70

50 60 800

Sample Output

Pizza 1 fits on the table.

Pizza 2 does not fit on the table.

Pizza 3 fits on the table.

圓桌放方形pizza,簡單的數學問題。


#include<iostream>

#include<cmath>

using namespace std;

int main()

{

   int r,w,l;

   int num=0;

   while((cin>>r>>w>>l)&&r){

                            num++;

       bool can=true;

       if(r*r*4>=(w*w+l*l))

       can =true;

       else can=false;

       if(can)

       cout<<"Pizza "<<num<<" fits on the table."<<endl;

       else if(can==false)

       cout<<"Pizza "<<num<<" does not fit on the table."<<endl;

       }

   //system("pause");

   return 0;

}


  1. 上一頁:
  2. 下一頁:
Copyright © 程式師世界 All Rights Reserved