程序師世界是廣大編程愛好者互助、分享、學習的平台,程序師世界有你更精彩!
首頁
編程語言
C語言|JAVA編程
Python編程
網頁編程
ASP編程|PHP編程
JSP編程
數據庫知識
MYSQL數據庫|SqlServer數據庫
Oracle數據庫|DB2數據庫
 程式師世界 >> 編程語言 >> C語言 >> 關於C語言 >> hdu 1541 Stars(最基礎的樹狀數組)

hdu 1541 Stars(最基礎的樹狀數組)

編輯:關於C語言

Stars

 

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 1287    Accepted Submission(s): 503

Problem Description

Astronomers often examine star maps where stars are represented by points on a plane and each star has Cartesian coordinates. Let the level of a star be an amount of the stars that are not higher and not to the right of the given star. Astronomers want to know the distribution of the levels of the stars.

 

For example, look at the map shown on the figure above. Level of the star number 5 is equal to 3 (it's formed by three stars with a numbers 1, 2 and 4). And the levels of the stars numbered by 2 and 4 are 1. At this map there are only one star of the level 0, two stars of the level 1, one star of the level 2, and one star of the level 3.

 

You are to write a program that will count the amounts of the stars of each level on a given map.

 

Input

The first line of the input file contains a number of stars N (1<=N<=15000). The following N lines describe coordinates of stars (two integers X and Y per line separated by a space, 0<=X,Y<=32000). There can be only one star at one point of the plane. Stars are listed in ascending order of Y coordinate. Stars with equal Y coordinates are listed in ascending order of X coordinate.

Output

The output should contain N lines, one number per line. The first line contains amount of stars of the level 0, the second does amount of stars of the level 1 and so on, the last line contains amount of stars of the level N-1.

Sample Input

5

1 1

5 1

7 1

3 3

5 5

 

Sample Output

1

2

1

1

0

   

       題目大意:y遞增,y不變x遞增的順序給出點你,這些點的左下方的點數代表這個點的級數,問0~N-1的級數有多少個?此題典型的數組數組,邊加入點邊更新點,用樹狀數組有很神奇的效果。

鏈接:http://acm.hdu.edu.cn/showproblem.php?pid=1541

代碼:

Cpp代碼

#include <iostream> 

#include <stdio.h> 

#include <memory.h> 

#include <cmath> 

using namespace std; 

 

int n, a[32005], val[32005]; 

 

void update(int p, int k) 

    while(p <= 32005) 

    { 

        a[p] += k; 

        p += p&(-p); 

    } 

 

int sum(int x) 

    int total = 0; 

    while(x > 0) 

    { 

        total += a[x]; 

        x -= x&(-x); 

    } 

    return total; 

 

int main() 

    int i, x, y; 

    while(scanf("%d", &n) != EOF) 

    { 

        memset(a, 0, sizeof(a)); 

        memset(val, 0, sizeof(val)); 

        for(i = 0; i < n; i++) 

        { 

            scanf("%d %d", &x, &y); 

            x++;    //注意!x++的原因:如果x=0更新時就會出現死循環所以都++ 

            val[sum(x)]++; 

            update(x, 1); 

        } 

        for(i = 0; i < n; i++) 

        { 

            printf("%d\n", val[i]); 

        } 

    } 

 

    return 0; 

}   

  1. 上一頁:
  2. 下一頁:
Copyright © 程式師世界 All Rights Reserved