程序師世界是廣大編程愛好者互助、分享、學習的平台,程序師世界有你更精彩!
首頁
編程語言
C語言|JAVA編程
Python編程
網頁編程
ASP編程|PHP編程
JSP編程
數據庫知識
MYSQL數據庫|SqlServer數據庫
Oracle數據庫|DB2數據庫
 程式師世界 >> 編程語言 >> C語言 >> C >> 關於C >> acm 1012

acm 1012

編輯:關於C
Joseph Time Limit: 1000MS Memory Limit: 10000K Total Submissions: 45627 Accepted: 17206 Description   The Joseph's problem is notoriously known. For those who are not familiar with the original problem: from among n people, numbered 1, 2, . . ., n, standing in circle every mth is going to be executed and only the life of the last remaining person will be saved. Joseph was smart enough to choose the position of the last remaining person, thus saving his life to give us the message about the incident. For example when n = 6 and m = 5 then the people will be executed in the order 5, 4, 6, 2, 3 and 1 will be saved.    Suppose that there are k good guys and k bad guys. In the circle the first k are good guys and the last k bad guys. You have to determine such minimal m that all the bad guys will be executed before the first good guy.   Input   The input file consists of separate lines containing k. The last line in the input file contains 0. You can suppose that 0 < k < 14. Output   The output file will consist of separate lines containing m corresponding to k in the input file. Sample Input   3 4 0 Sample Output   5 30  
Source Code  
  
Problem: 1012    
Memory: 188K  Time: 0MS   
Language: C  Result: Accepted   
  
Source Code   
#include<stdio.h>  
  
int main()  
{  
    int num[14]={0,2,7,5,30,169,441,1872,7632,1740,93313,459901,1358657,2504881};  
    int k;  
    while(1)  
    {  
        scanf("%d",&k);  
        if(k==0)  
           break;  
        printf("%d\n",num[k]);             
    }  
    system("pause");  
    return 0;  
}  

 

   
  1. 上一頁:
  2. 下一頁:
Copyright © 程式師世界 All Rights Reserved