程序師世界是廣大編程愛好者互助、分享、學習的平台,程序師世界有你更精彩!
首頁
編程語言
C語言|JAVA編程
Python編程
網頁編程
ASP編程|PHP編程
JSP編程
數據庫知識
MYSQL數據庫|SqlServer數據庫
Oracle數據庫|DB2數據庫
 程式師世界 >> 編程語言 >> C語言 >> C++ >> C++入門知識 >> bzoj 1636: [Usaco2007 Jan]Balanced Lineup,bzojusaco2007

bzoj 1636: [Usaco2007 Jan]Balanced Lineup,bzojusaco2007

編輯:C++入門知識

bzoj 1636: [Usaco2007 Jan]Balanced Lineup,bzojusaco2007


1636: [Usaco2007 Jan]Balanced Lineup

Time Limit: 5 Sec  Memory Limit: 64 MB
Submit: 772  Solved: 560
線段樹裸題。。。
初學者可參照為模板

Description

For the daily milking, Farmer John's N cows (1 <= N <= 50,000) always line up in the same order. One day Farmer John decides to organize a game of Ultimate Frisbee with some of the cows. To keep things simple, he will take a contiguous range of cows from the milking lineup to play the game. However, for all the cows to have fun they should not differ too much in height. Farmer John has made a list of Q (1 <= Q <= 200,000) potential groups of cows and their heights (1 <= height <= 1,000,000). For each group, he wants your help to determine the difference in height between the shortest and the tallest cow in the group.

每天,農夫 John 的N(1 <= N <= 50,000)頭牛總是按同一序列排隊. 有一天, John 決定讓一些牛們玩一場飛盤比賽. 他准備找一群在對列中為置連續的牛來進行比賽. 但是為了避免水平懸殊,牛的身高不應該相差太大. John 准備了Q (1 <= Q <= 180,000) 個可能的牛的選擇和所有牛的身高 (1 <= 身高 <= 1,000,000). 他想知道每一組裡面最高和最低的牛的身高差別. 

注意: 在最大數據上, 輸入和輸出將占用大部分運行時間. 

Input

* Line 1: Two space-separated integers, N and Q. * Lines 2..N+1: Line i+1 contains a single integer that is the height of cow i * Lines N+2..N+Q+1: Two integers A and B (1 <= A <= B <= N), representing the range of cows from A to B inclusive.

第1行:N,Q 第2到N+1行:每頭牛的身高 第N+2到N+Q+1行:兩個整數A和B,表示從A到B的所有牛。(1<=A<=B<=N)

Output

6 3 1 7 3 4 2 5 1 5 4 6 2 2  

Sample Input

* Lines 1..Q: Each line contains a single integer that is a response
to a reply and indicates the difference in height between the
tallest and shortest cow in the range.
  輸出每行一個數,為最大數與最小數的差

Sample Output

6
3
0    
#include<cstdio>
#include <iostream>
#define M 50010
int max(int a,int b){return a>b?a:b;}
int min(int a,int b){return a<b?a:b;}
struct tree{int l,r,minn,maxx;}tr[4*M];
int a[M];
void make(int l,int r,int p)
{
    tr[p].l=l;
    tr[p].r=r;
    if(l==r){
        tr[p].minn=a[l];
        tr[p].maxx=a[l];
        return ;
    }
    int mid=(l+r)>>1;
    make(l,mid,p<<1);
    make(mid+1,r,p<<1|1);
    tr[p].minn=min(tr[p<<1].minn,tr[p<<1|1].minn);
    tr[p].maxx=max(tr[p<<1].maxx,tr[p<<1|1].maxx);
}
int fmin(int l,int r,int x)
{
    if(tr[x].l==l&&tr[x].r==r) return tr[x].minn; 
    int mid=(tr[x].l+tr[x].r)>>1,q=x<<1; 
    if(r<=mid) return fmin(l,r,q); 
    else if(l>mid) return fmin(l,r,q+1); 
    else return min(fmin(l,mid,q),fmin(mid+1,r,q+1)); 
}
int fmax(int l,int r,int x)
{
    if(tr[x].l==l&&tr[x].r==r) return tr[x].maxx; 
    int mid=(tr[x].l+tr[x].r)>>1; 
    if(r<=mid) return fmax(l,r,x<<1); 
    else if(l>mid) return fmax(l,r,x<<1|1); 
    else return max(fmax(l,mid,x<<1),fmax(mid+1,r,x<<1|1)); 
}
int main()
{
    int n,m,i,x,y;
    scanf("%d%d",&n,&m);
    for(i=1;i<=n;i++) scanf("%d",&a[i]);    
    make(1,n,1);
    for(i=0;i<m;i++){
        scanf("%d%d",&x,&y);
        printf("%d\n",fmax(x,y,1)-fmin(x,y,1));
    }
}

 

 

  1. 上一頁:
  2. 下一頁:
Copyright © 程式師世界 All Rights Reserved