程序師世界是廣大編程愛好者互助、分享、學習的平台,程序師世界有你更精彩!
首頁
編程語言
C語言|JAVA編程
Python編程
網頁編程
ASP編程|PHP編程
JSP編程
數據庫知識
MYSQL數據庫|SqlServer數據庫
Oracle數據庫|DB2數據庫
 程式師世界 >> 編程語言 >> C語言 >> C++ >> C++入門知識 >> 實驗7:Problem B: STL——集合運算,problemstl

實驗7:Problem B: STL——集合運算,problemstl

編輯:C++入門知識

實驗7:Problem B: STL——集合運算,problemstl


Description

集合的運算就是用給定的集合去指定新的集合。設A和B是集合,則它們的並差交補集分別定義如下: A∪B={x|x∈A∨x∈B} A∩B={x|x∈A∧x∈B} A-B={x|x∈A∧x不屬於 B} SA ={x|x∈(A∪B)∧x 不屬於A} SB ={x|x∈(A∪B)∧x 不屬於B}

 

 

 

Input

第一行輸入一個正整數T,表示總共有T組測試數據。(T<=200) 然後下面有2T行,每一行都有n+1個數字,其中第一個數字是n(0<=n<=100),表示該行後面還有n個數字輸入。

 

Output

對於每組測試數據,首先輸出測試數據序號,”Case #.NO”, 接下來輸出共7行,每行都是一個集合, 前2行分別輸出集合A、B,接下5行來分別輸出集合A、B的並(A u B)、交(A n B)、差(A – B)、補。 集合中的元素用“{}”擴起來,且元素之間用“, ”隔開。

 

Sample Input

1 4 1 2 3 1 0

Sample Output

Case# 1: A = {1, 2, 3} B = {} A u B = {1, 2, 3} A n B = {} A - B = {1, 2, 3} SA = {} SB = {1, 2, 3}

HINT

 

如果你會用百度搜一下關鍵字“stl set”,這個題目我相信你會很快很輕松的做出來。加油哦!
 //在<algorithm>中存在求交並補集的函數
set_union
set_intersection
set_difference
我是從這個網站上搜到的,可以借鑒一下!http://blog.chinaunix.net/uid-9950859-id-99130.html
存在一種頭文件#include<bits/stdc++.h>包含了所有C++頭文件。但有些OJ不能使用。
#include<iostream>
#include<algorithm>
#include<set>

using namespace std;
void print(const set<int> &t)
{
    set<int>::iterator it;
    cout << "{";
    for(it = t.begin(); it != t.end(); it++)
        if(it == t.begin()) cout << *it;
        else cout << ", " << *it;
    cout << "}" << endl;
}

int main()
{
    int i,n;
    cin>>n;
    for(i=1;i<=n;i++)
    {
        cout<<"Case# "<<i<<":"<<endl;
        int j,m,k;
        set<int> A;
        set<int> B;
        set<int> tmp1,tmp2,tmp3,tmp4,tmp5;
        cin>>m;
        for(j=0;j<m;j++)
        {
            int t;
            cin>>t;
            A.insert(t);
        }
        cin>>k;
        for(j=0;j<k;j++)
        {
            int t;
            cin>>t;
            B.insert(t);
        }
        cout<<"A = ";
        print(A);
        cout<<"B = ";
        print(B);

        set_union(A.begin(), A.end(), B.begin(), B.end(), inserter(tmp1, tmp1.begin()));
        cout<<"A u B = ";
        print(tmp1);
        set_intersection(A.begin(), A.end(), B.begin(), B.end(), inserter(tmp2, tmp2.begin()));
        cout<<"A n B = ";
        print(tmp2);
        set_difference(A.begin(), A.end(), B.begin(), B.end(), inserter(tmp3, tmp3.begin()));
        cout<<"A - B = ";
        print(tmp3);
        set_difference(tmp1.begin(), tmp1.end(), A.begin(), A.end(), inserter(tmp4, tmp4.begin()));
        cout<<"SA = ";
        print(tmp4);
        set_difference(tmp1.begin(), tmp1.end(), B.begin(), B.end(), inserter(tmp5, tmp5.begin()));
        cout<<"SB = ";
        print(tmp5);
    }
    return 0;
}

 

  1. 上一頁:
  2. 下一頁:
Copyright © 程式師世界 All Rights Reserved