程序師世界是廣大編程愛好者互助、分享、學習的平台,程序師世界有你更精彩!
首頁
編程語言
C語言|JAVA編程
Python編程
網頁編程
ASP編程|PHP編程
JSP編程
數據庫知識
MYSQL數據庫|SqlServer數據庫
Oracle數據庫|DB2數據庫
 程式師世界 >> 編程語言 >> C語言 >> C++ >> C++入門知識 >> HDU2317:Nasty Hacks

HDU2317:Nasty Hacks

編輯:C++入門知識

Problem Description
You are the CEO of Nasty Hacks Inc., a company that creates small pieces of malicious software which teenagers may use
to fool their friends. The company has just finished their first product and it is time to sell it. You want to make as much money as possible and consider advertising in order to increase sales. You get an analyst to predict the expected revenue, both with and without advertising. You now want to make a decision as to whether you should advertise or not, given the expected revenues.


 


Input
The input consists of n cases, and the first line consists of one positive integer giving n. The next n lines each contain 3 integers, r, e and c. The first, r, is the expected revenue if you do not advertise, the second, e, is the expected revenue if you do advertise, and the third, c, is the cost of advertising. You can assume that the input will follow these restrictions: -106 ≤ r, e ≤ 106 and 0 ≤ c ≤ 106.
 


Output
Output one line for each test case: “advertise”, “do not advertise” or “does not matter”, presenting whether it is most profitable to advertise or not, or whether it does not make any difference.
 


Sample Input
3
0 100 70
100 130 30
-100 -70 40


Sample Output
advertise
does not matter
do not advertise

 

每天必水啊啊啊

[cpp]
#include <stdio.h>  
 
int main() 

    int t; 
    scanf("%d",&t); 
    while(t--) 
    { 
        int r,e,c; 
        scanf("%d%d%d",&r,&e,&c); 
        if(e-c > r) 
        printf("advertise\n"); 
        else if(e-c == r) 
        printf("does not matter\n"); 
        else if(e-c < r) 
        printf("do not advertise\n"); 
    } 
 
    return 0; 

#include <stdio.h>

int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        int r,e,c;
        scanf("%d%d%d",&r,&e,&c);
        if(e-c > r)
        printf("advertise\n");
        else if(e-c == r)
        printf("does not matter\n");
        else if(e-c < r)
        printf("do not advertise\n");
    }

    return 0;
}

 

 

 

  1. 上一頁:
  2. 下一頁:
Copyright © 程式師世界 All Rights Reserved