程序師世界是廣大編程愛好者互助、分享、學習的平台,程序師世界有你更精彩!
首頁
編程語言
C語言|JAVA編程
Python編程
網頁編程
ASP編程|PHP編程
JSP編程
數據庫知識
MYSQL數據庫|SqlServer數據庫
Oracle數據庫|DB2數據庫
 程式師世界 >> 編程語言 >> C語言 >> C++ >> C++入門知識 >> POJ1700:Crossing River(過河問題),poj1700crossing

POJ1700:Crossing River(過河問題),poj1700crossing

編輯:C++入門知識

POJ1700:Crossing River(過河問題),poj1700crossing


                  POJ1700

題目鏈接:http://poj.org/problem?id=1700 Time Limit:1000MS     Memory Limit:10000KB     64bit IO Format:%I64d & %I64u  

Description

A group of N people wishes to go across a river with only one boat, which can at most carry two persons. Therefore some sort of shuttle arrangement must be arranged in order to row the boat back and forth so that all people may cross. Each person has a different rowing speed; the speed of a couple is determined by the speed of the slower one. Your job is to determine a strategy that minimizes the time for these people to get across.

Input

The first line of the input contains a single integer T (1 <= T <= 20), the number of test cases. Then T cases follow. The first line of each case contains N, and the second line contains N integers giving the time for each people to cross the river. Each case is preceded by a blank line. There won't be more than 1000 people and nobody takes more than 100 seconds to cross.

Output

For each test case, print a line containing the total number of seconds required for all the N people to cross the river.

Sample Input

1
4
1 2 5 10

Sample Output

17

題解:

這是一個過河坐船問題,一共有兩個策略
①最快和次快過去,最快回;最慢和次慢過去,次快回,最快的和次快的過去,t1=a[1]+a[0]+a[n-1]+a[1]+a[1]。②最快和最慢過去,最快回;最快和次快過去,最快回,最快的和次慢的過去,t2=a[n-1]+a[0]+a[1]+a[0]+a[n-2]。選擇兩者中用時較少的一個策略執行,判斷t1與t2大小,只需要判斷2a[1]是否大於a[0]+a[n-2],如此便將最慢和次慢送過河,對剩下n-2個人循環處理。注意當n=1、n=2、n=3時直接相加處理即可.

#include<iostream>
#include<algorithm>
using namespace std;
int n,a[1006];
int main()
{
  int t,i;
  cin>>t;;
  while(t--)
{
  int f=0;//每次f歸0
  cin>>n;
  for(i=1; i<=n; i++)
    cin>>a[i];
  sort(a,a+n+1);
  while(n)
{
  if(n==1)
{
    f+=a[1];
      break;
}
  if(n==2)
{
      f+=a[2];
      break;
}
  if(n==3)
{
      f+=a[1]+a[2]+a[3];
      break;
}
  if(n>3)
{
      if(2*a[2]>(a[1]+a[n-1]))
    f+=2*a[1]+a[n]+a[n-1];
else
    f+=2*a[2]+a[1]+a[n];
    n=n-2;//注意循環
}
}
  cout<<f<<endl;
}
  return 0;
}

  1. 上一頁:
  2. 下一頁:
Copyright © 程式師世界 All Rights Reserved