程序師世界是廣大編程愛好者互助、分享、學習的平台,程序師世界有你更精彩!
首頁
編程語言
C語言|JAVA編程
Python編程
網頁編程
ASP編程|PHP編程
JSP編程
數據庫知識
MYSQL數據庫|SqlServer數據庫
Oracle數據庫|DB2數據庫
 程式師世界 >> 編程語言 >> C語言 >> C++ >> C++入門知識 >> Foreign Exchange(交換生換位置),foreignexchange

Foreign Exchange(交換生換位置),foreignexchange

編輯:C++入門知識

Foreign Exchange(交換生換位置),foreignexchange


           Foreign Exchange

Your non-profit organization (iCORE - international Confederation of Revolver Enthusiasts) coordinates a very successful foreign student exchange program. Over the last few years, demand has sky-rocketed and now you need assistance with your task. The program your organization runs works as follows: All candidates are asked for their original location and the location they would like to go to. The program works out only if every student has a suitable exchange partner. In other words, if a student wants to go from A to B, there must be another student who wants to go from B to A. This was an easy task when there were only about 50 candidates, however now there are up to 500000 candidates!

Input

The input file contains multiple cases. Each test case will consist of a line containing n – the number of candidates (1 ≤ n ≤ 500000), followed by n lines representing the exchange information for each candidate. Each of these lines will contain 2 integers, separated by a single space, representing the candidate’s original location and the candidate’s target location respectively. Locations will be represented by nonnegative integer numbers. You may assume that no candidate will have his or her original location being the same as his or her target location as this would fall into the domestic exchange program. The input is terminated by a case where n = 0; this case should not be processed.

Output

For each test case, print ‘YES’ on a single line if there is a way for the exchange program to work out, otherwise print ‘NO’.

Sample Input

10

1 2

2 1

3 4

4 3

100 200

200 100

57 2

2 57

1 2

2 1

10

1 2

3 4

5 6

7 8

9 10

11 12

13 14

15 16

17 18

19 20

0

Sample Output

YES

NO

 

題解:開兩個數組s【i】,t【i】,然後把數組數據從小到大排序,循環如果能以一一對應相等,則說明可以交換,輸出YES,否則只要有一個不相等就輸出NO.

 

#include<iostream>
#include<algorithm>
using namespace std;
int s[500000],t[500000];//注意數組大小
int main()
{
  int n,i;
  while(cin>>n&&n)
{
  for(i=0; i<n; i++)
    cin>>s[i]>>t[i];
  sort(s,s+n);//排序
  sort(t,t+n);
  int f=0;
  for(i=0; i<n; i++)
{
    if(s[i]!=t[i])
  {
      f=1;
      break;
  }
}

if(f)
    cout<<"NO"<<endl;
else
    cout<<"YES"<<endl;
}
return 0;

}

 

  1. 上一頁:
  2. 下一頁:
Copyright © 程式師世界 All Rights Reserved