程序師世界是廣大編程愛好者互助、分享、學習的平台,程序師世界有你更精彩!
首頁
編程語言
C語言|JAVA編程
Python編程
網頁編程
ASP編程|PHP編程
JSP編程
數據庫知識
MYSQL數據庫|SqlServer數據庫
Oracle數據庫|DB2數據庫
 程式師世界 >> 編程語言 >> C語言 >> C++ >> C++入門知識 >> hdu 3613 exkmp,hduexkmp

hdu 3613 exkmp,hduexkmp

編輯:C++入門知識

hdu 3613 exkmp,hduexkmp


題目鏈接

http://acm.hdu.edu.cn/showproblem.php?pid=3613

Best Reward

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 940    Accepted Submission(s): 390


Problem Description After an uphill battle, General Li won a great victory. Now the head of state decide to reward him with honor and treasures for his great exploit. 

One of these treasures is a necklace made up of 26 different kinds of gemstones, and the length of the necklace is n. (That is to say: n gemstones are stringed together to constitute this necklace, and each of these gemstones belongs to only one of the 26 kinds.) 

In accordance with the classical view, a necklace is valuable if and only if it is a palindrome - the necklace looks the same in either direction. However, the necklace we mentioned above may not a palindrome at the beginning. So the head of state decide to cut the necklace into two part, and then give both of them to General Li. 

All gemstones of the same kind has the same value (may be positive or negative because of their quality - some kinds are beautiful while some others may looks just like normal stones). A necklace that is palindrom has value equal to the sum of its gemstones' value. while a necklace that is not palindrom has value zero. 

Now the problem is: how to cut the given necklace so that the sum of the two necklaces's value is greatest. Output this value. 

 

 

Input The first line of input is a single integer T (1 ≤ T ≤ 10) - the number of test cases. The description of these test cases follows. 

For each test case, the first line is 26 integers: v1, v2, ..., v26 (-100 ≤ vi ≤ 100, 1 ≤ i ≤ 26), represent the value of gemstones of each kind. 

The second line of each test case is a string made up of charactor 'a' to 'z'. representing the necklace. Different charactor representing different kinds of gemstones, and the value of 'a' is v1, the value of 'b' is v2, ..., and so on. The length of the string is no more than 500000. 

 

 

Output Output a single Integer: the maximum value General Li can get from the necklace.  

 

Sample Input 2 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 aba 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 acacac   Sample Output 1 6   原串的前綴與(原串前後顛倒得到的反串)的前綴長度相同,那麼原串對應的這段字符則為回文串。模擬算出ex[i],可以得出ex[i]+i=len,且如果前半段(到i)不是回文,則直接判斷(i+1)以後的是否為回文即可。  
#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <queue>
#include <stack>

using namespace std;
const int inf=0x3fffffff;
const int maxn=500000+10;
char str1[maxn],str2[maxn];
int nt[maxn],ex1[maxn],ex2[maxn],dp[maxn];
int kind[26];
int slen,tlen;
void get_next(char *s)
{
    nt[0]=slen;
    int l,r;
    for(l=0;l<slen-1&&s[l]==s[l+1];l++);
    nt[1]=l;
    l=1;
    for(int i=2;i<slen;i++)
    {
        r=l+nt[l]-1;
        if(nt[i-l]+i-1>=r)
        {
            int p=r-i+1>0?r-i+1:0;
            while(p+i<slen&&s[p]==s[p+i])
                p++;
            nt[i]=p;
            l=i;
        }
        else
            nt[i]=nt[i-l];
    }
}
void get_extand(char *s,char *t,int *ex)
{
    memset(nt,0,sizeof(nt));
    get_next(s);
    int l=0,r;
    while(l<slen&&s[l]==t[l])
        l++;
    ex[0]=l;
    l=0;
    for(int i=1;i<tlen;i++)
    {
        r=ex[l]+l-1;
        if(nt[i-l]+i-1>=r)
        {
            int p=r-i+1>0?r-i+1:0;
            while(p+i<tlen&&s[p]==t[i+p])
                p++;
            ex[i]=p;
            l=i;
        }
        else
            ex[i]=nt[i-l];
    }
}
int main()
{
    //freopen("in.txt","r",stdin);
    int T;
    scanf("%d",&T);
    while(T--)
    {
        for(int i=0;i<26;i++)
            scanf("%d",&kind[i]);
        scanf("%s",str1);
        memset(dp,0,sizeof(dp));
        dp[0]=0;
        tlen=slen=strlen(str1);
        for(int i=1;i<=slen;i++)
            dp[i]=dp[i-1]+kind[str1[i-1]-'a'];
         for(int i=slen-1,j=0;i>=0;i--,j++)
            str2[j]=str1[i];
        str2[slen]='\0';
        get_extand(str1,str2,ex1);
        get_extand(str2,str1,ex2);
        int ans=0;
        for(int i=0;i<slen;i++)
        {
            int temp=0;
            if(i&&ex1[i]+i==slen)
            {
                int p=ex1[i];
                temp+=dp[p];
                if(ex2[p]+p==slen)
                {
                    temp+=dp[slen]-dp[p];
                }
            }
            else
            {
                int p=i+1;
                if(ex2[p]+p==slen)
                    temp+=dp[slen]-dp[p];
            }
            ans=ans>temp?ans:temp;
            //printf("i->%d ans->%d\n",i,ans);
        }
        printf("%d\n",ans);
    }
    return 0;
}

 

  1. 上一頁:
  2. 下一頁:
Copyright © 程式師世界 All Rights Reserved