程序師世界是廣大編程愛好者互助、分享、學習的平台,程序師世界有你更精彩!
首頁
編程語言
C語言|JAVA編程
Python編程
網頁編程
ASP編程|PHP編程
JSP編程
數據庫知識
MYSQL數據庫|SqlServer數據庫
Oracle數據庫|DB2數據庫
 程式師世界 >> 編程語言 >> C語言 >> C++ >> C++入門知識 >> 線段樹 [成段更新] HDU 1698 Just a Hook

線段樹 [成段更新] HDU 1698 Just a Hook

編輯:C++入門知識

成段更新,需要用到延遲標記(或者說懶惰標記),簡單來說就是每次更新的時候不要更新到底,用延遲標記使得更新延遲到下次需要更新or詢問到的時候.

此處建議在紙上模擬一遍。


Problem Description
In the game of DotA, Pudge’s meat hook is actually the most horrible thing for most of the heroes. The hook is made up of several consecutive metallic sticks which are of the same length.

 

 

\



 

Now Pudge wants to do some operations on the hook.

Let us number the consecutive metallic sticks of the hook from 1 to N. For each operation, Pudge can change the consecutive metallic sticks, numbered from X to Y, into cupreous sticks, silver sticks or golden sticks.
The total value of the hook is calculated as the sum of values of N metallic sticks. More precisely, the value for each kind of stick is calculated as follows:

For each cupreous stick, the value is 1.
For each silver stick, the value is 2.
For each golden stick, the value is 3.

Pudge wants to know the total value of the hook after performing the operations.
You may consider the original hook is made up of cupreous sticks.

 

Input
The input consists of several test cases. The first line of the input is the number of the cases. There are no more than 10 cases.
For each case, the first line contains an integer N, 1<=N<=100,000, which is the number of the sticks of Pudge’s meat hook and the second line contains an integer Q, 0<=Q<=100,000, which is the number of the operations.
Next Q lines, each line contains three integers X, Y, 1<=X<=Y<=N, Z, 1<=Z<=3, which defines an operation: change the sticks numbered from X to Y into the metal kind Z, where Z=1 represents the cupreous kind, Z=2 represents the silver kind and Z=3 represents the golden kind.

 

Output
For each case, print a number in a line representing the total value of the hook after the operations. Use the format in the example.

 

Sample Input
1
10
2
1 5 2
5 9 3

Sample Output
Case 1: The total value of the hook is 24.
 

#include <stdio.h>
#include <iostream>
using namespace std;
const int N = 400000;
int tree[N], flag[N], x, y, value;
void build(int l, int r, int k) {
	tree[k] = 1; //初始為1
	flag[k] = 0;
	if (l == r)
		return;
	int m = (l + r) / 2;
	build(l, m, k * 2); //k*2 即為k的左子樹
	build(m + 1, r, k * 2 + 1); // k*2+1 即為k的右子樹
	tree[k] = tree[k * 2] + tree[k * 2 + 1]; //更新當前節點的指, 即左子樹+右子樹
}

//向下更新。 k為更新的節點的,m為更新區間的長度
//將k節點的信息更新到它的左右子樹上
void down(int k, int m) {
	if (flag[k]) {
		flag[k * 2] = flag[k * 2 + 1] = flag[k];
		tree[k * 2] = (m - (m / 2)) * flag[k];
		tree[k * 2 + 1] = m / 2 * flag[k];
		flag[k] = 0;
	}
}

void update(int l, int r, int k) {
	if (x <= l && y >= r) {
		flag[k] = value; //存儲當前的 value
		tree[k] = (r - l + 1) * value;
		return;
	}
	down(k, r - l + 1); //更新k節點
	int m = (l + r) / 2;
	if (x <= m)
		update(l, m, k * 2);
	if (y > m)
		update(m + 1, r, k * 2 + 1);
	tree[k] = tree[k * 2] + tree[k * 2 + 1];
}

int main() {
	//freopen("in.txt", "r", stdin);
	int T , n , m;
	scanf("%d",&T);
	for (int cas = 1; cas <= T; cas ++) {
		scanf("%d%d",&n,&m);
		build(1 , n , 1);
		while(m--) {
			scanf("%d %d %d", &x, &y, &value);
			update( 1, n ,1);
		}
		printf("Case %d: The total value of the hook is %d.\n",cas , tree[1]);
	}
	return 0;
}

 

  1. 上一頁:
  2. 下一頁:
Copyright © 程式師世界 All Rights Reserved