程序師世界是廣大編程愛好者互助、分享、學習的平台,程序師世界有你更精彩!
首頁
編程語言
C語言|JAVA編程
Python編程
網頁編程
ASP編程|PHP編程
JSP編程
數據庫知識
MYSQL數據庫|SqlServer數據庫
Oracle數據庫|DB2數據庫
 程式師世界 >> 編程語言 >> C語言 >> C++ >> C++入門知識 >> UVA 445 - Marvelous Mazes

UVA 445 - Marvelous Mazes

編輯:C++入門知識

 Marvelous Mazes
Your mission, if you decide to accept it, is to create a maze drawing program. A maze will consist of the alphabetic characters A-Z, * (asterisk), and spaces.


Input and Output
Your program will get the information for the mazes from the input file. This file will contain lines of characters which your program must interpret to draw a maze. Each row of the maze will be described by a series of numbers and characters, where the numbers before a character tell how many times that character will be used. If there are multiple digits in a number before a character, then the number of times to repeat the character is the sum of the digits before that character.

The lowercase letter "b" will be used in the input file to represent spaces in the maze. The descriptions for different rows in the maze will be separated by an exclamation point (!) or by an end of line.


Descriptions for different mazes will be separated by a blank line in both input and output. The input file will be terminated by an end of file.

There is no limit to the number of rows in a maze or the number of mazes in a file, though no row will contain more than 132 characters.

Happy mazing!


Sample Input

1T1b5T!1T2b1T1b2T!1T1b1T2b2T!1T3b1T1b1T!3T3b1T!1T3b1T1b1T!5T1*1T
 
11X21b1X
4X1b1X
Sample Output

T TTTTT
T  T TT
T T  TT
T   T T
TTT   T
T   T T
TTTTT*T
 
XX   X
XXXX X題意:給出一個字符串,由數字、大寫字母、*  、和b組成,當s[i]=='b'時,輸出換行;當是數字時,如s[i]=2,s[i+1]='T',連續輸出兩個T;如果出現連續數字,則輸出這些連續數字的和個字母,如11A,則輸出AA。

#include<stdio.h>
#include<string.h>
int main()
{
    char s[140];
    int i,j,sum,len;
    while(gets(s)!= NULL)
    {
        len=strlen(s);
        sum=0;
        for(i=0;i<len;i++)
        {
            if(s[i]>='0'&&s[i]<='9') /*如果是數字*/
              sum+=s[i]-'0';  /*求輸出個數*/
            else
            {   if(s[i]=='!') /*換行*/
                    printf("\n");
                for(j=sum;j>0;j--)
                {
                    if(s[i]=='b') /*輸出空格*/
                      printf(" ");
                    else /*輸出字母或 * */
                      printf("%c",s[i]);
                }
                sum=0; /*記得輸出後清零*/
            }
        }
        printf("\n");
    }
    return 0;
}

 

  1. 上一頁:
  2. 下一頁:
Copyright © 程式師世界 All Rights Reserved