程序師世界是廣大編程愛好者互助、分享、學習的平台,程序師世界有你更精彩!
首頁
編程語言
C語言|JAVA編程
Python編程
網頁編程
ASP編程|PHP編程
JSP編程
數據庫知識
MYSQL數據庫|SqlServer數據庫
Oracle數據庫|DB2數據庫
 程式師世界 >> 編程語言 >> C語言 >> C++ >> C++入門知識 >> hdu 1501 Zipper (dfs+記憶化搜索)

hdu 1501 Zipper (dfs+記憶化搜索)

編輯:C++入門知識

hdu 1501 Zipper (dfs+記憶化搜索)


Zipper

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 6491 Accepted Submission(s): 2341


Problem Description Given three strings, you are to determine whether the third string can be formed by combining the characters in the first two strings. The first two strings can be mixed arbitrarily, but each must stay in its original order.

For example, consider forming "tcraete" from "cat" and "tree":

String A: cat
String B: tree
String C: tcraete


As you can see, we can form the third string by alternating characters from the two strings. As a second example, consider forming "catrtee" from "cat" and "tree":

String A: cat
String B: tree
String C: catrtee


Finally, notice that it is impossible to form "cttaree" from "cat" and "tree".

Input The first line of input contains a single positive integer from 1 through 1000. It represents the number of data sets to follow. The processing for each data set is identical. The data sets appear on the following lines, one data set per line.

For each data set, the line of input consists of three strings, separated by a single space. All strings are composed of upper and lower case letters only. The length of the third string is always the sum of the lengths of the first two strings. The first two strings will have lengths between 1 and 200 characters, inclusive.


Output For each data set, print:

Data set n: yes

if the third string can be formed from the first two, or

Data set n: no

if it cannot. Of course n should be replaced by the data set number. See the sample output below for an example.

Sample Input
3
cat tree tcraete
cat tree catrtee
cat tree cttaree

Sample Output
Data set 1: yes
Data set 2: yes
Data set 3: no

Source Pacific Northwest 2004

加一個二維數組,記錄該狀態是否已經到達!

#include"stdio.h"
#include"string.h"
#include"queue"
#include"vector"
#include"algorithm"
using namespace std;
#define N 405
#define max(a,b) (a>b?a:b)
int n1,n2,n3,dp[N][N];
char s1[N],s2[N],s3[N*2];
int dfs(int i,int j,int k)
{
    if(k==n3)
        return 1;
    if(dp[i][j])
        return 0;
    dp[i][j]=1;
    if(s1[i]==s3[k])
    {
        if(dfs(i+1,j,k+1))
            return 1;
    }
    if(s2[j]==s3[k])
    {
        if(dfs(i,j+1,k+1))
            return 1;
    }
    return 0;
}
int main()
{
    int T,cnt=1;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%s %s %s",s1,s2,s3);
        n1=strlen(s1);
        n2=strlen(s2);
        n3=strlen(s3);
        printf("Data set %d: ",cnt++);
        memset(dp,0,sizeof(dp));
        if(dfs(0,0,0))
            printf("yes\n");
        else
            printf("no\n");
    }
    return 0;
}


  1. 上一頁:
  2. 下一頁:
Copyright © 程式師世界 All Rights Reserved