程序師世界是廣大編程愛好者互助、分享、學習的平台,程序師世界有你更精彩!
首頁
編程語言
C語言|JAVA編程
Python編程
網頁編程
ASP編程|PHP編程
JSP編程
數據庫知識
MYSQL數據庫|SqlServer數據庫
Oracle數據庫|DB2數據庫
 程式師世界 >> 編程語言 >> C語言 >> C++ >> C++入門知識 >> HDOJ 1297 Children’s Queue

HDOJ 1297 Children’s Queue

編輯:C++入門知識


JAVA大數....

Children’s Queue

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 10390 Accepted Submission(s): 3333


Problem Description There are many students in PHT School. One day, the headmaster whose name is PigHeader wanted all students stand in a line. He prescribed that girl can not be in single. In other words, either no girl in the queue or more than one girl stands side by side. The case n=4 (n is the number of children) is like
FFFF, FFFM, MFFF, FFMM, MFFM, MMFF, MMMM
Here F stands for a girl and M stands for a boy. The total number of queue satisfied the headmaster’s needs is 7. Can you make a program to find the total number of queue with n children?

Input There are multiple cases in this problem and ended by the EOF. In each case, there is only one integer n means the number of children (1<=n<=1000)
Output For each test case, there is only one integer means the number of queue satisfied the headmaster’s needs.
Sample Input
1
2
3

Sample Output
1
2
4

Author SmallBeer (CML)
Source 杭電ACM集訓隊訓練賽(VIII)

import java.util.*;
import java.math.*;

public class Main
{
	public static void main(String[] args)
	{
		Scanner cin=new Scanner(System.in);
		
		BigInteger[] a=new BigInteger[1100];
		a[1]=BigInteger.valueOf(1);
		a[2]=BigInteger.valueOf(2);
		a[3]=BigInteger.valueOf(4);
		a[4]=BigInteger.valueOf(7);
		for(int i=5;i<=1000;i++)
		{
			a[i]=a[i-4].add(a[i-2].add(a[i-1]));
		}
		
		while(cin.hasNextInt())
		{
			int n=cin.nextInt();
			System.out.println(a[n]);
		}
	}
}




  1. 上一頁:
  2. 下一頁:
Copyright © 程式師世界 All Rights Reserved