程序師世界是廣大編程愛好者互助、分享、學習的平台,程序師世界有你更精彩!
首頁
編程語言
C語言|JAVA編程
Python編程
網頁編程
ASP編程|PHP編程
JSP編程
數據庫知識
MYSQL數據庫|SqlServer數據庫
Oracle數據庫|DB2數據庫
 程式師世界 >> 編程語言 >> C語言 >> C++ >> C++入門知識 >> hdu 2647 Reward

hdu 2647 Reward

編輯:C++入門知識

Reward

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3554 Accepted Submission(s): 1077


Problem Description Dandelion's uncle is a boss of a factory. As the spring festival is coming , he wants to distribute rewards to his workers. Now he has a trouble about how to distribute the rewards.
The workers will compare their rewards ,and some one may have demands of the distributing of rewards ,just like a's reward should more than b's.Dandelion's unclue wants to fulfill all the demands, of course ,he wants to use the least money.Every work's reward will be at least 888 , because it's a lucky number.
Input One line with two integers n and m ,stands for the number of works and the number of demands .(n<=10000,m<=20000)
then m lines ,each line contains two integers a and b ,stands for a's reward should be more than b's.
Output For every case ,print the least money dandelion 's uncle needs to distribute .If it's impossible to fulfill all the works' demands ,print -1.
Sample Input
2 1
1 2
2 2
1 2
2 1

Sample Output
1777
-1

拓撲排序+優先隊列


#include"stdio.h"
#include"string.h"
#include"queue"
using namespace std;
#define N 10005
#define M 20005
struct st
{
    int x,v;        //存點坐標和價值
    friend bool operator<(st a,st b)
    {
        return a.v>b.v;
    }
};
struct node
{
    int v,next;
}bian[M];
int indeg[N],e;
int head[N];
void add(int u,int v)        //存邊的信息
{
    bian[e].v=v;
    bian[e].next=head[u];
    head[u]=e++;
}
int top_sort(int n)
{
    int mark[N],i,x,cnt=0,sum=0,v;
    memset(mark,0,sizeof(mark));
    priority_queueq;
    st cur,next;
    cur.v=888;
    for(i=1;i<=n;i++)
    {
        if(indeg[i]==0)
        {
            cur.x=i;
            mark[i]=1;
            cnt++;
            q.push(cur);
        }
    }
    while(!q.empty())           //每次找出入度為零的點,更新它指向的點信息。
    {
        cur=q.top();
        q.pop();
        sum+=cur.v;           
        x=cur.x;
        for(i=head[x];i!=-1;i=bian[i].next)
        {
            v=bian[i].v;
            indeg[v]--;
            if(indeg[v]==0&&!mark[v])
            {
                mark[v]=1;
                cnt++;
                next.v=cur.v+1;
                next.x=v;
                q.push(next);
            }
        }
    }
    if(cnt==n)
        return sum;
    return -1;
}
int main()
{
    int n,m,i,v,u;
    while(scanf("%d%d",&n,&m)!=-1)
    {
        memset(head,-1,sizeof(head));
        memset(indeg,0,sizeof(indeg));
        e=0;
        while(m--)
        {
            scanf("%d%d",&v,&u);
            add(u,v);       
            indeg[v]++;
        }
        int t=top_sort(n);
        printf("%d\n",t);
    }
    return 0;
}




  1. 上一頁:
  2. 下一頁:
Copyright © 程式師世界 All Rights Reserved