程序師世界是廣大編程愛好者互助、分享、學習的平台,程序師世界有你更精彩!
首頁
編程語言
C語言|JAVA編程
Python編程
網頁編程
ASP編程|PHP編程
JSP編程
數據庫知識
MYSQL數據庫|SqlServer數據庫
Oracle數據庫|DB2數據庫
 程式師世界 >> 編程語言 >> C語言 >> C++ >> C++入門知識 >> poj 2485 Highways

poj 2485 Highways

編輯:C++入門知識

Highways Time Limit: 1000MS Memory Limit: 65536K Total Submissions: 20757 Accepted: 9601

Description

The island nation of Flatopia is perfectly flat. Unfortunately, Flatopia has no public highways. So the traffic is difficult in Flatopia. The Flatopian government is aware of this problem. They're planning to build some highways so that it will be possible to drive between any pair of towns without leaving the highway system.

Flatopian towns are numbered from 1 to N. Each highway connects exactly two towns. All highways follow straight lines. All highways can be used in both directions. Highways can freely cross each other, but a driver can only switch between highways at a town that is located at the end of both highways.

The Flatopian government wants to minimize the length of the longest highway to be built. However, they want to guarantee that every town is highway-reachable from every other town.

Input

The first line of input is an integer T, which tells how many test cases followed.
The first line of each case is an integer N (3 <= N <= 500), which is the number of villages. Then come N lines, the i-th of which contains N integers, and the j-th of these N integers is the distance (the distance should be an integer within [1, 65536]) between village i and village j. There is an empty line after each test case.

Output

For each test case, you should output a line contains an integer, which is the length of the longest road to be built such that all the villages are connected, and this value is minimum.

Sample Input

1

3
0 990 692
990 0 179
692 179 0

Sample Output

692

Hint

Huge input,scanf is recommended.

還是最小生成樹、prim。

至於輸出最長的一條連通邊,只要保證總長度最小,最長邊一定最小。

#include"stdio.h"
#include"string.h"
#include"math.h"
#define N 505
#define inf 100000
int map[N][N],mark[N],dis[N];
int prim(int n)
{
	int i,index,min,max=0;
	for(i=0;imap[index][i])
				dis[i]=map[index][i];
	}
	return max;
}
int main()
{
	int T,i,j,n;
	scanf("%d",&T);
	while(T--)
	{
		scanf("%d",&n);
		for(i=0;i




  1. 上一頁:
  2. 下一頁:
Copyright © 程式師世界 All Rights Reserved