程序師世界是廣大編程愛好者互助、分享、學習的平台,程序師世界有你更精彩!
首頁
編程語言
C語言|JAVA編程
Python編程
網頁編程
ASP編程|PHP編程
JSP編程
數據庫知識
MYSQL數據庫|SqlServer數據庫
Oracle數據庫|DB2數據庫
 程式師世界 >> 編程語言 >> C語言 >> C++ >> C++入門知識 >> poj 1753 Flip Game

poj 1753 Flip Game

編輯:C++入門知識

Flip Game

Time Limit: 1000MS Memory Limit: 65536K Total Submissions: 28190 Accepted: 12221

Description

Flip game is played on a rectangular 4x4 field with two-sided pieces placed on each of its 16 squares. One side of each piece is white and the other one is black and each piece is lying either it's black or white side up. Each round you flip 3 to 5 pieces, thus changing the color of their upper side from black to white and vice versa. The pieces to be flipped are chosen every round according to the following rules:
Choose any one of the 16 pieces.
Flip the chosen piece and also all adjacent pieces to the left, to the right, to the top, and to the bottom of the chosen piece (if there are any).
\Consider the following position as an example:

bwbw
wwww
bbwb
bwwb
Here "b" denotes pieces lying their black side up and "w" denotes pieces lying their white side up. If we choose to flip the 1st piece from the 3rd row (this choice is shown at the picture), then the field will become:

bwbw
bwww
wwwb
wwwb
The goal of the game is to flip either all pieces white side up or all pieces black side up. You are to write a program that will search for the minimum number of rounds needed to achieve this goal.

Input

The input consists of 4 lines with 4 characters "w" or "b" each that denote game field position.

Output

Write to the output file a single integer number - the minimum number of rounds needed to achieve the goal of the game from the given position. If the goal is initially achieved, then write 0. If it's impossible to achieve the goal, then write the word "Impossible" (without quotes).

Sample Input

bwwb
bbwb
bwwb
bwww

Sample Output

4

主要用位運算和(優先)隊列搜索,每個格子有兩種狀態,則共有2^16=65536;

每個棋子有兩個狀態可以用二進制表示,如黑為1,白為0;

由位運算規則:1^1=0,0^1=1;

對16個格子進行翻轉操作有16種方式,

可以令一些格子為1,另一些為0來模擬;

1100

1000

0000

0000

轉換成十進制為2^15+2^14+2^11=51200,

即16個十進制數存入change[]數組;

搜索過程中每個出現的狀態都會被標記,再出隊,因此,不會出現死循環。

具體代碼如下:

#include"stdio.h"
#include"iostream"
#include"queue"
using namespace std;
#define N 65536
int dir[4][2]={1,0,-1,0,0,-1,0,1};
int change[16];     
int visit[N];
struct node    // 用優先隊列,一般隊列也能過
{
	int state,step;
	friend bool operator<(node a,node b)
	{
		return a.step>b.step;
	}
};
void inti()        //若提前求出16個操作狀態存入數組可以省去該函數
{
	int i,j,x,y,t,temp,k=0;
	for(i=0;i<4;i++)
	{
		for(j=0;j<4;j++)
		{
			temp=0;
			temp^=(1<<((3-i)*4+3-j));
			for(t=0;t<4;t++)
			{
				x=dir[t][0]+i;
				y=dir[t][1]+j;
				if(x<0||y<0||x>3||y>3)
					continue;
				temp^=(1<<((3-x)*4+3-y));
			}
			change[k++]=temp;
		}
	}
}
int bfs(int t)
{
	int i;
	memset(visit,0,sizeof(visit));
	priority_queueq;
	node cur,next;
	cur.state=t;
	cur.step=0;
	q.push(cur);
	visit[t]=1;
	while(!q.empty())
	{
		cur=q.top();
		q.pop();
		if(cur.state==0||cur.state==N-1)
			return cur.step;
		for(i=0;i<16;i++)
		{
			next.state=cur.state^change[i];
			next.step=cur.step+1;
			if(!visit[next.state])
			{
				q.push(next);
				visit[next.state]=1;
			}
		}
	}
	return -1;
}
int main()
{
	int i,j,t,ans;
	inti();
	char chess[5][5];
	while(scanf("%s",chess[0])!=-1)
	{
		for(i=1;i<4;i++)
			scanf("%s",chess[i]);
		t=0;
		for(i=0;i<4;i++)
			for(j=0;j<4;j++)
			{
				if(chess[i][j]=='b')
					t^=1<<((3-i)*4+3-j);       //此處把異或改為加也行,
			}
		ans=bfs(t);
		if(ans==-1)
			printf("Impossible\n");
		else
			printf("%d\n",ans);
	}
    return 0;
}



  1. 上一頁:
  2. 下一頁:
Copyright © 程式師世界 All Rights Reserved