程序師世界是廣大編程愛好者互助、分享、學習的平台,程序師世界有你更精彩!
首頁
編程語言
C語言|JAVA編程
Python編程
網頁編程
ASP編程|PHP編程
JSP編程
數據庫知識
MYSQL數據庫|SqlServer數據庫
Oracle數據庫|DB2數據庫
 程式師世界 >> 編程語言 >> C語言 >> C++ >> C++入門知識 >> 1074. Reversing Linked List (25)

1074. Reversing Linked List (25)

編輯:C++入門知識

1074. Reversing Linked List (25)

時間限制 300 ms
內存限制 32000 kB
代碼長度限制 16000 B
判題程序 Standard 作者 CHEN, Yue

Given a constant K and a singly linked list L, you are supposed to reverse the links of every K elements on L. For example, given L being 1→2→3→4→5→6, if K = 3, then you must output 3→2→1→6→5→4; if K = 4, you must output 4→3→2→1→5→6.

Input Specification:

Each input file contains one test case. For each case, the first line contains the address of the first node, a positive N (<= 105) which is the total number of nodes, and a positive K (<=N) which is the length of the sublist to be reversed. The address of a node is a 5-digit nonnegative integer, and NULL is represented by -1.

Then N lines follow, each describes a node in the format:

Address Data Next

where Address is the position of the node, Data is an integer, and Next is the position of the next node.

Output Specification:

For each case, output the resulting ordered linked list. Each node occupies a line, and is printed in the same format as in the input.

Sample Input:
00100 6 4
00000 4 99999
00100 1 12309
68237 6 -1
33218 3 00000
99999 5 68237
12309 2 33218
Sample Output:
00000 4 33218
33218 3 12309
12309 2 00100
00100 1 99999
99999 5 68237
68237 6 -1
解題思路:
可能有多個鏈表干擾,這時候可以用hash來查找在同一個鏈表裡面的節點。
#include"iostream"
#include"stdio.h"
#include"stdlib.h"
#include"string.h"
#include"algorithm"
#include"vector"
using namespace std;

#define MAX 100000
#define LEN 6
typedef struct node{
	char addr[LEN];
	int d;
	char next[LEN];	
}Node;
int main(){
	long N,K;
	char start[LEN];
	scanf("%s%ld%ld",start,&N,&K);
	
	Node b[MAX];/*題目的內存還是很大的,空間換時間*/
	vector a;
	
	for(int i=0;i

  1. 上一頁:
  2. 下一頁:
Copyright © 程式師世界 All Rights Reserved