程序師世界是廣大編程愛好者互助、分享、學習的平台,程序師世界有你更精彩!
首頁
編程語言
C語言|JAVA編程
Python編程
網頁編程
ASP編程|PHP編程
JSP編程
數據庫知識
MYSQL數據庫|SqlServer數據庫
Oracle數據庫|DB2數據庫
 程式師世界 >> 編程語言 >> C語言 >> C++ >> C++入門知識 >> POJ 1405 Heritage

POJ 1405 Heritage

編輯:C++入門知識

Description

Your rich uncle died recently, and the heritage needs to be divided among your relatives and the church (your uncle insisted in his will that the church must get something). There are N relatives (N <= 18) that were mentioned in the will. They are sorted in descending order according to their importance (the first one is the most important). Since you are the computer scientist in the family, your relatives asked you to help them. They need help, because there are some blanks in the will left to be filled. Here is how the will looks:

Relative #1 will get 1 / ... of the whole heritage,
Relative #2 will get 1 / ... of the whole heritage,
---------------------- ...
Relative #n will get 1 / ... of the whole heritage.

The logical desire of the relatives is to fill the blanks in such way that the uncle's will is preserved (i.e the fractions are non-ascending and the church gets something) and the amount of heritage left for the church is minimized.
Input

The only line of input contains the single integer N (1 <= N <= 18).
Output

Output the numbers that the blanks need to be filled (on separate lines), so that the heritage left for the church is minimized.
Sample Input

2
Sample Output

2
3
題意:將一份財產分成n份,1/x1, 1/x2, 1/x3, ...,1/xn.使得x1>x2>x3>...>xn,讓教堂分得的財產最少. xn = x1 * x2 * ...*xn-1 + 1.
如果前k個分剩下1/c,因為1/c>1/(c+1)>1/(c+2)>...所以下一個拿1/(c+1),剩下1/(c * (c+1)).

 

#include<stdio.h> 
#include<stdlib.h> 
#define inf 1000000000 
#define maxn 100000 
int len1, len2, len3, len[18]; 
long long  a[maxn], b[maxn], ans[maxn], res[18][maxn]; 
void setAns() 

    for (int i = 0; i < len3; i++) 
    { 
        ans[i] = 0; 
    } 

void copy() 

    for (int i = 0; i < len3; i++) 
    { 
        a[i] = ans[i]; 
    } 
    len1 = len3; 

void multiply() 

    int i, j; 
    setAns(); 
    for (i = 0; i < len2; i++) 
    { 
        for (j = 0; j < len1; j++) 
        { 
            ans[i+j] += a[j] * b[i]; 
            ans[i+j+1] += ans[i+j] / inf; 
            if (ans[i+j+1] && len3 <= i + j + 1) 
            { 
                len3 = i + j + 2; 
            } 
            else if (len3 <= i + j) 
            { 
                len3 = i + j + 1; 
            } 
            ans[i+j] %= inf; 
        } 
    } 

void plus() 

    int r; 
    for (len2 = 0, r = 1; len2 < len1; len2++) 
    { 
        r += a[len2]; 
        if (r >= inf) 
        { 
            b[len2] = r - inf; 
            r = 1; 
        } 
        else 
        { 
            b[len2] = r; 
            r = 0; 
        } 
    } 
    if (r) 
    { 
        b[len2++] = r; 
    } 

int main() 

    int i, j, n; 
    scanf("%d", &n); 
    a[0] = 2; 
    len1 = 1; 
    printf("2\n"); 
    for (i = 2; i <= n; i++) 
    { 
        plus(); 
        printf("%lld", b[len2-1]); 
        for (j = len2 - 2; j >= 0; j--) 
        { 
            printf("%.9lld", b[j]); 
        }printf("\n"); 
        if (i < n) 
        { 
            multiply(); 
            copy(); 
        } 
    } 
    return 0; 


作者:ultimater

  1. 上一頁:
  2. 下一頁:
Copyright © 程式師世界 All Rights Reserved