程序師世界是廣大編程愛好者互助、分享、學習的平台,程序師世界有你更精彩!
首頁
編程語言
C語言|JAVA編程
Python編程
網頁編程
ASP編程|PHP編程
JSP編程
數據庫知識
MYSQL數據庫|SqlServer數據庫
Oracle數據庫|DB2數據庫
 程式師世界 >> 編程語言 >> C語言 >> C++ >> C++入門知識 >> HDU 1018 Big Number

HDU 1018 Big Number

編輯:C++入門知識


Problem Description
In many applications very large integers numbers are required. Some of these applications are using keys for secure transmission of data, encryption, etc. In this problem you are given a number, you have to determine the number of digits in the factorial of the number.
 

Input
Input consists of several lines of integer numbers. The first line contains an integer n, which is the number of cases to be tested, followed by n lines, one integer 1 ≤ n ≤ 107 on each line.
 

Output
The output contains the number of digits in the factorial of the integers appearing in the input.
 

Sample Input
2
10
20
 

Sample Output
7
19
這個題的意思是:給你一個數,讓你求出N!由多少位數構成,比如輸出10,它的階乖是3628800 由7位數構成,這時你要輸出7;
解題思路:
1.可以暴力,N的階乖的位數等於LOG10(N!)=LOG10(1)+.....LOG10(N);
2.Stirling公式:n!與√(2πn) * n^n * e^(-n)的值十分接近
故log10(n!) = log(n!) / log(10) = ( n*log(n) - n + 0.5*log(2*π*n))/log(n);

解法一:
LANGUAGE:C++
CODE:
#include<stdio.h> 
#include<math.h> 
double reback(int n) 

    double cnt=0; 
    for(int i=2;i<=n;i++) 
    { 
        cnt+=log10(i); 
    } 
    return cnt; 

 
int main() 

    int cas,n; 
    scanf("%d",&cas); 
    while(cas--) 
    { 
        scanf("%d",&n); 
        printf("%d\n",(int)reback(n)+1); 
    } 
    return 0; 

解法二:
LANGUAGE:C++
CODE:
#include <stdio.h> 
#include <math.h> 
 
const double PI = acos(-1.0); 
const double ln_10 = log(10.0); 
 
double reback(int N) 

    return ceil((N*log(double(N))-N+0.5*log(2.0*N*PI))/ln_10); 
}     
 
int main() 

    int cas,n; 
    scanf("%d",&cas); 
    while(cas--) 
    { 
        scanf("%d",&n); 
        if(n<=1)printf("1\n"); 
        else printf("%.0lf\n",reback(n)); 
    } 
    return 0; 


  1. 上一頁:
  2. 下一頁:
Copyright © 程式師世界 All Rights Reserved