程序師世界是廣大編程愛好者互助、分享、學習的平台,程序師世界有你更精彩!
首頁
編程語言
C語言|JAVA編程
Python編程
網頁編程
ASP編程|PHP編程
JSP編程
數據庫知識
MYSQL數據庫|SqlServer數據庫
Oracle數據庫|DB2數據庫
 程式師世界 >> 編程語言 >> C語言 >> C++ >> C++入門知識 >> poj_1274 The Perfect Stall

poj_1274 The Perfect Stall

編輯:C++入門知識

The Perfect Stall
Time Limit: 1000MS
Memory Limit: 10000K
Total Submissions: 14473
Accepted: 6621
題目鏈接:http://poj.org/problem?id=1274
Description
Farmer John completed his new barn just last week, complete with all the latest milking technology. Unfortunately, due to engineering problems, all the stalls in the new barn are different. For the first week, Farmer John randomly assigned cows to stalls, but it quickly became clear that any given cow was only willing to produce milk in certain stalls. For the last week, Farmer John has been collecting data on which cows are willing to produce milk in which stalls. A stall may be only assigned to one cow, and, of course, a cow may be only assigned to one stall.
Given the preferences of the cows, compute the maximum number of milk-producing assignments of cows to stalls that is possible.
Input
The input includes several cases. For each case, the first line contains two integers, N (0 <= N <= 200) and M (0 <= M <= 200). N is the number of cows that Farmer John has and M is the number of stalls in the new barn. Each of the following N lines corresponds to a single cow. The first integer (Si) on the line is the number of stalls that the cow is willing to produce milk in (0 <= Si <= M). The subsequent Si integers on that line are the stalls in which that cow is willing to produce milk. The stall numbers will be integers in the range (1..M), and no stall will be listed twice for a given cow.
Output
For each case, output a single line with a single integer, the maximum number of milk-producing stall assignments that can be made.
Sample Input
5 5
2 2 5
3 2 3 4
2 1 5
3 1 2 5
1 2
Sample Output
4
Source
USACO 40
解題思路:
         這是一個二分匹配的簡單題,就是查找最佳匹配,根據廣搜來查找增廣路,如果查找到就結束查找,否則繼續查找增廣路,在計算數量
代碼:
#include <iostream> 
#include<cstdio> 
#include<cstring> 
 
#define maxn 205 
using namespace std; 
 
int n,m; 
int map[maxn][maxn]; 
int visited[maxn]; 
int mak[maxn];//匹配 
 
bool BFS(int x) 

    int i; 
 
    for(i=1;i<=m;i++) 
    { 
 
        if(map[x][i] && !visited[i]) 
        { 
            visited[i]=1; 
            if(!mak[i] || BFS(mak[i])) 
            { 
                mak[i]=x; 
                return true; 
            } 
        } 
    } 
    return false; 

 
 
void solve() 

    int i; 
    int count=0; 
    memset(mak,0,sizeof(mak)); 
    for(i=1;i<=n;i++) 
    { 
        memset(visited,0,sizeof(visited)); 
        if(BFS(i)) 
        { 
            count++; 
        } 
    } 
    printf("%d\n",count); 

 
 
int main() 

    int x,y; 
    int i,j; 
    while(scanf("%d%d",&n,&m)!=EOF) 
    { 
        memset(map,0,sizeof(map)); 
        for(i=1;i<=n;i++) 
        { 
            scanf("%d",&x); 
            for(j=0;j<x;j++) 
            { 
                scanf("%d",&y); 
                map[i][y]=1;//第i頭牛願意到第y個牛場 
            } 
        } 
        solve(); 
    } 
    return 0; 

  1. 上一頁:
  2. 下一頁:
Copyright © 程式師世界 All Rights Reserved