程序師世界是廣大編程愛好者互助、分享、學習的平台,程序師世界有你更精彩!
首頁
編程語言
C語言|JAVA編程
Python編程
網頁編程
ASP編程|PHP編程
JSP編程
數據庫知識
MYSQL數據庫|SqlServer數據庫
Oracle數據庫|DB2數據庫
 程式師世界 >> 編程語言 >> C語言 >> C++ >> C++入門知識 >> HDU 1800 Flying to the Mars map水題

HDU 1800 Flying to the Mars map水題

編輯:C++入門知識

Flying to the Mars
Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 6545    Accepted Submission(s): 2130


Problem Description


In the year 8888, the Earth is ruled by the PPF Empire . As the population growing , PPF needs to find more land for the newborns . Finally , PPF decides to attack Kscinow who ruling the Mars . Here the problem comes! How can the soldiers reach the Mars ? PPF convokes his soldiers and asks for their suggestions . “Rush … ” one soldier answers. “Shut up ! Do I have to remind you that there isn’t any road to the Mars from here!” PPF replies. “Fly !” another answers. PPF smiles :“Clever guy ! Although we haven’t got wings , I can buy some magic broomsticks from HARRY POTTER to help you .” Now , it’s time to learn to fly on a broomstick ! we assume that one soldier has one level number indicating his degree. The soldier who has a higher level could teach the lower , that is to say the former’s level > the latter’s . But the lower can’t teach the higher. One soldier can have only one teacher at most , certainly , having no teacher is also legal. Similarly one soldier can have only one student at most while having no student is also possible. Teacher can teach his student on the same broomstick .Certainly , all the soldier must have practiced on the broomstick before they fly to the Mars! Magic broomstick is expensive !So , can you help PPF to calculate the minimum number of the broomstick needed .
For example :
There are 5 soldiers (A B C D E)with level numbers : 2 4 5 6 4;
One method :
C could teach B; B could teach A; So , A B C are eligible to study on the same broomstick.
D could teach E;So D E are eligible to study on the same broomstick;
Using this method , we need 2 broomsticks.
Another method:
D could teach A; So A D are eligible to study on the same broomstick.
C could teach B; So B C are eligible to study on the same broomstick.
E with no teacher or student are eligible to study on one broomstick.
Using the method ,we need 3 broomsticks.
……

After checking up all possible method, we found that 2 is the minimum number of broomsticks needed.
 

Input
Input file contains multiple test cases.
In a test case,the first line contains a single positive number N indicating the number of soldiers.(0<=N<=3000)
Next N lines :There is only one nonnegative integer on each line , indicating the level number for each soldier.( less than 30 digits);
 

Output
For each case, output the minimum number of broomsticks on a single line.
 

Sample Input
4
10
20
30
04
5
2
3
4
3
4
 

Sample Output
1
2
 

Author
PPF@JLU
 

Recommend
lcy
 

題意:輸入一堆數字 看一堆數中最少有多少個上升子串(不連續的子串) 1個數字 單獨也算一個子串

思路:

每個串去掉一串最長的 再去掉一串次長的。。。。。

到最後肯定剩下某個出現次數最多的數字  所以本題就是找那個數字出現的最多 最多的次數是多少

肯定用map喽

 

[cpp]
#include<stdio.h> 
#include<map> 
using namespace std; 
int main() 

    __int64 i,n,max; 
    map<__int64,__int64>mp; 
    while(scanf("%I64d",&n)!=EOF) 
    { 
        mp.clear(); 
        while(n--) 
        { 
            scanf("%I64d",&i); 
            mp[i]++; 
        } 
        map<__int64,__int64>::iterator it; 
        max=0; 
        for(it=mp.begin();it!=mp.end();it++) 
            if(max<it->second) max=it->second; 
        printf("%I64d\n",max); 
    } 
    return 0; 

  1. 上一頁:
  2. 下一頁:
Copyright © 程式師世界 All Rights Reserved