程序師世界是廣大編程愛好者互助、分享、學習的平台,程序師世界有你更精彩!
首頁
編程語言
C語言|JAVA編程
Python編程
網頁編程
ASP編程|PHP編程
JSP編程
數據庫知識
MYSQL數據庫|SqlServer數據庫
Oracle數據庫|DB2數據庫
 程式師世界 >> 編程語言 >> C語言 >> C++ >> C++入門知識 >> Poj 2250 Compromise

Poj 2250 Compromise

編輯:C++入門知識

Compromise
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 4965   Accepted: 2266   Special Judge
Description
In a few months the European Currency Union will become a reality. However, to join the club, the Maastricht criteria must be fulfilled, and this is not a trivial task for the countries (maybe except for Luxembourg). To enforce that Germany will fulfill the criteria, our government has so many wonderful options (raise taxes, sell stocks, revalue the gold reserves,...) that it is really hard to choose what to do.

Therefore the German government requires a program for the following task:
Two politicians each enter their proposal of what to do. The computer then outputs the longest common subsequence of words that occurs in both proposals. As you can see, this is a totally fair compromise (after all, a common sequence of words is something what both people have in mind).

Your country needs this program, so your job is to write it for us.
Input
The input will contain several test cases.
Each test case consists of two texts. Each text is given as a sequence of lower-case words, separated by whitespace, but with no punctuation. Words will be less than 30 characters long. Both texts will contain less than 100 words and will be terminated by a line containing a single '#'.
Input is terminated by end of file.
Output
For each test case, print the longest common subsequence of words occuring in the two texts. If there is more than one such sequence, any one is acceptable. Separate the words by one blank. After the last word, output a newline character.
Sample Input
die einkommen der landwirte
sind fuer die abgeordneten ein buch mit sieben siegeln
um dem abzuhelfen
muessen dringend alle subventionsgesetze verbessert werden
#
die steuern auf vermoegen und einkommen
sollten nach meinung der abgeordneten
nachdruecklich erhoben werden
dazu muessen die kontrollbefugnisse der finanzbehoerden
dringend verbessert werden
#
Sample Output
die einkommen der abgeordneten muessen dringend verbessert werden
開始學習DP............(受鸨神影響)。本題要求的是最長公共子“單詞”,輸入很煩人.......然後就是套用最長公共子串的模版了.......打印的話則是借助標志從終點向起點前進,遞歸打印(和圖論中打印路徑差不多)。
[cpp] 
#include <iostream> 
#include <algorithm> 
#include <cmath> 
#include <cstdio> 
#include <cstdlib> 
#include <cstring> 
#include <string> 
#include <vector> 
#include <set> 
#include <queue> 
#include <stack> 
#include <climits>//形如INT_MAX一類的 
#define MAX 1050 
#define INF 0x7FFFFFFF 
# define eps 1e-5 
using namespace std; 
char a[101][31],b[101][31]; 
int len[6005][6005]; 
int index[6005][6005];//標志 
void print(int i,int j)//模版打印 

    if(i>=1 && j>=1) 
    { 
        if(index[i][j] == 0) 
        { 
            print(i-1,j-1); 
            if(j  != 1) 
            cout << ' '; 
            cout << b[j-1]; 
        } 
        if(index[i][j] == 1) 
        { 
            print(i,j-1); 
        } 
        if(index[i][j] == -1) 
        { 
            print(i-1,j); 
        } 
    } 

 
int main() 

    int i,j; 
    char d[50]; 
    while(cin >> d) 
    { 
        memset(a,'\0',sizeof(a)); 
        memset(b,'\0',sizeof(b)); 
        i=0; 
        while(strcmp(d,"#")!=0)//第一個字典輸入 
        { 
            strcpy(a[i],d); 
            i++; 
            scanf("%s",d); 
        } 
        scanf("%s",d); 
        j=0; 
        while(strcmp(d,"#")!=0)//第二個字典輸入 
        { 
            strcpy(b[j],d); 
            j++; 
            scanf("%s",d); 
        } 
        int len1 = i; 
        int len2 = j; 
        for(i=0; i<len1; i++) 
        { 
            len[i][0] = 0; 
        } 
        for(i=0; i<len2; i++) 
        { 
            len[0][i] = 0; 
        } 
        for(i=1; i<=len1; i++)//模版最長公共子串 
            for(j=1; j<=len2; j++) 
            { 
                if(strcmp(a[i-1],b[j-1]) == 0 ) 
                { 
                    len[i][j] = len[i-1][j-1] + 1; 
                    index[i][j] = 0; 
                } 
                else 
                { 
                    if(len[i-1][j] > len[i][j-1]) 
                    { 
                        len[i][j] = len[i-1][j]; 
                        index[i][j] = -1; 
                    } 
                    else 
                    { 
                        len[i][j] = len[i][j-1]; 
                        index[i][j] = 1; 
                    } 
                } 
            } 
        print(len1,len2);//從終點開始,遞歸打印 
        cout << endl; 
        cout << endl; 
        //cout << len[len1][len2] << endl; 
    } 
    return 0; 


 

  1. 上一頁:
  2. 下一頁:
Copyright © 程式師世界 All Rights Reserved