程序師世界是廣大編程愛好者互助、分享、學習的平台,程序師世界有你更精彩!
首頁
編程語言
C語言|JAVA編程
Python編程
網頁編程
ASP編程|PHP編程
JSP編程
數據庫知識
MYSQL數據庫|SqlServer數據庫
Oracle數據庫|DB2數據庫
 程式師世界 >> 編程語言 >> C語言 >> C++ >> C++入門知識 >> hdu 1113 暴力以及map string的用法 這個比較帥重要

hdu 1113 暴力以及map string的用法 這個比較帥重要

編輯:C++入門知識

Word Amalgamation
Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 1646    Accepted Submission(s): 758


Problem Description
In millions of newspapers across the United States there is a word game called Jumble. The object of this game is to solve a riddle, but in order to find the letters that appear in the answer it is necessary to unscramble four words. Your task is to write a program that can unscramble words.
 

Input
The input contains four parts:

1. a dictionary, which consists of at least one and at most 100 words, one per line;
2. a line containing XXXXXX, which signals the end of the dictionary;
3. one or more scrambled `words' that you must unscramble, each on a line by itself; and
4. another line containing XXXXXX, which signals the end of the file.

All words, including both dictionary words and scrambled words, consist only of lowercase English letters and will be at least one and at most six characters long. (Note that the sentinel XXXXXX contains uppercase X's.) The dictionary is not necessarily in sorted order, but each word in the dictionary is unique.
 

Output
For each scrambled word in the input, output an alphabetical list of all dictionary words that can be formed by rearranging the letters in the scrambled word. Each word in this list must appear on a line by itself. If the list is empty (because no dictionary words can be formed), output the line ``NOT A VALID WORD" instead. In either case, output a line containing six asterisks to signal the end of the list.
 

Sample Input
tarp
given
score
refund
only
trap
work
earn
course
pepper
part
XXXXXX
resco
nfudre
aptr
sett
oresuc
XXXXXX
 

Sample Output
score
******
refund
******
part
tarp
trap
******
NOT A VALID WORD
******
course
******
 
最重要的還是map的用法
 
題意:
輸入字典  XXXXXX結束字典的輸入  然後輸入字符串  如果字符串能夠組成字典中的串就輸出該串 否則輸出NOT A VALID WORD
輸入XXXXXX結束改組數據輸入
思路:把字典的每個串中的每個字符從小到大排序  詢問串也是  然後原串與排序後的串作為一組添加進map 即可
 
暴力方法
[cpp]
#include <iostream> 
#include <algorithm> 
#include <stdio.h> 
#include <string.h> 
using namespace std; 
struct node 

    char s[10]; 
    char st[10]; 
    bool operator<(const node&b)const 
    { 
       return strcmp(s,b.s)<0; 
    } 
}rc[103]; 
int main() 

    char s[10]; 
    int i,n=0; 
    while(scanf("%s",s),strcmp(s,"XXXXXX")!=0) 
    { 
        strcpy(rc[n].s,s); 
        sort(s,s+strlen(s)); 
        //puts(s); 
        strcpy(rc[n].st,s); 
        n++; 
    } 
    sort(rc,rc+n); 
    int f; 
    while(scanf("%s",s),strcmp(s,"XXXXXX")!=0) 
    { 
        sort(s,s+strlen(s)); 
        f=0; 
        for(i=0;i<n;i++) 
          if(strcmp(rc[i].st,s)==0) 
            f=1,printf("%s\n",rc[i].s); 
        if(!f) 
        printf("NOT A VALID WORD\n"); 
        printf("******\n"); 
    } 
    return 0; 

[cpp] 
/*map的用法 很帥  string的用法  很帥*/ 
[cpp] 
#include<iostream> 
#include<stdio.h> 
#include<map> 
#include<string> 
#include<algorithm> 
using namespace std; 
map <string ,string > node; 
int main() 

    string s; 
    while(cin>>s&&s!="XXXXXX") 
    { 
        string t=s; 
        sort (s.begin(),s.end());//這個方法好帥  哥哥折服了 
        node.insert(pair<string,string>(t,s)); 
 } 
 while(cin>>s) 
 { 
  if(s=="XXXXXX") break; 
  int flag=1; 
  map<string,string>::iterator it; 
    sort(s.begin (),s.end ()); 
    for(it=node.begin ();it!=node.end();it++) 
    { 
     if(it->second==s) 
     { 
      flag=0;cout<<it->first<<endl; 
     } 
    } 
    if(flag) cout<<"NOT A VALID WORD"<<endl; 
    cout<<"******"<<endl; 
 } 
 return 0; 


 
 
 

  1. 上一頁:
  2. 下一頁:
Copyright © 程式師世界 All Rights Reserved