程序師世界是廣大編程愛好者互助、分享、學習的平台,程序師世界有你更精彩!
首頁
編程語言
C語言|JAVA編程
Python編程
網頁編程
ASP編程|PHP編程
JSP編程
數據庫知識
MYSQL數據庫|SqlServer數據庫
Oracle數據庫|DB2數據庫
 程式師世界 >> 編程語言 >> C語言 >> C++ >> C++入門知識 >> poj1721 CARDS

poj1721 CARDS

編輯:C++入門知識

CARDS
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 1030   Accepted: 542
Description
Alice and Bob have a set of N cards labelled with numbers 1 ... N (so that no two cards have the same label) and a shuffle machine. We assume that N is an odd integer.
The shuffle machine accepts the set of cards arranged in an arbitrary order and performs the following operation of double shuffle : for all positions i, 1 <= i <= N, if the card at the position i is j and the card at the position j is k, then after the completion of the operation of double shuffle, position i will hold the card k.

Alice and Bob play a game. Alice first writes down all the numbers from 1 to N in some random order: a1, a2, ..., aN. Then she arranges the cards so that the position ai holds the card numbered ai+1, for every 1 <= i <= N-1, while the position aN holds the card numbered a1.

This way, cards are put in some order x1, x2, ..., xN, where xi is the card at the ith position.

Now she sequentially performs S double shuffles using the shuffle machine described above. After that, the cards are arranged in some final order p1, p2, ..., pN which Alice reveals to Bob, together with the number S. Bob's task is to guess the order x1, x2, ..., xN in which Alice originally put the cards just before giving them to the shuffle machine.
Input
The first line of the input contains two integers separated by a single blank character : the odd integer N, 1 <= N <= 1000, the number of cards, and the integer S, 1 <= S <= 1000, the number of double shuffle operations.
The following N lines describe the final order of cards after all the double shuffles have been performed such that for each i, 1 <= i <= N, the (i+1)st line of the input file contains pi (the card at the position i after all double shuffles).
Output
The output should contain N lines which describe the order of cards just before they were given to the shuffle machine.
For each i, 1 <= i <= N, the ith line of the output file should contain xi (the card at the position i before the double shuffles).
Sample Input
7 4
6
3
1
2
4
7
5
Sample Output
4
7
5
6
1
2
3
Source
CEOI 1998
[cpp] 
#include<iostream> 
#include<cstdlib> 
#include<stdio.h> 
using namespace std; 
int a[1010]; 
int b[1010]; 
int c[1010]; 
int n,m; 
int count; 
void solve() 

    while(1) 
    { 
        for(int i=1;i<=n;i++) 
        { 
            b[i]=c[c[i]]; 
        } 
        count++; 
        int j; 
        for(j=1;j<=n;j++) 
        { 
            if(b[j]!=a[j]) 
            break; 
        } 
        if(j>n) break; 
        for(int i=1;i<=n;i++) 
        c[i]=b[i]; 
    } 

int main() 

    while(scanf("%d%d",&n,&m)!=EOF) 
    { 
        for(int i=1;i<=n;i++) 
        { 
            scanf("%d",&a[i]);c[i]=a[i]; 
        } 
        if(n==1) 
        { 
            printf("%d\n",a[1]); 
            continue; 
        } 
        count=0; 
        solve(); 
        //cout<<count<<endl; 
        m=m%count; 
        m=count-m; 
        int q=0; 
        while(q<m) 
        { 
            for(int i=1;i<=n;i++) 
            b[i]=a[a[i]]; 
            for(int i=1;i<=n;i++) 
            a[i]=b[i]; 
            q++; 
        } 
        for(int i=1;i<=n;i++) 
        cout<<b[i]<<endl; 
    } 

  1. 上一頁:
  2. 下一頁:
Copyright © 程式師世界 All Rights Reserved