程序師世界是廣大編程愛好者互助、分享、學習的平台,程序師世界有你更精彩!
首頁
編程語言
C語言|JAVA編程
Python編程
網頁編程
ASP編程|PHP編程
JSP編程
數據庫知識
MYSQL數據庫|SqlServer數據庫
Oracle數據庫|DB2數據庫
 程式師世界 >> 編程語言 >> C語言 >> C++ >> C++入門知識 >> poj 1430 Binary Stirling Numbers

poj 1430 Binary Stirling Numbers

編輯:C++入門知識

第二類Stirling數是把包含n個元素的集合劃分為正好k個非空子集的方法的數目。
遞推公式為:
S(n,k) = 0(n<k||k=0),
S(n,n) = S(n,1) = 1,
S(n,k) = S(n-1,k-1) + kS(n-1,k).

下面這幅圖是從維基百科截出來的,有一個二進制斯特靈數與組合數的轉化公式。而組合數模二的余數就很容易了。

 

我們知道,組合數C(N,M)=N ! / M ! /(N-M)!,因而只需求得階乘質因數分解式中二的重數即可解決問題。
而N !質因數分解後2的重數可用下式來計算之。
K=N/2+N/2^2+N/2^3+....

 

Description

The Stirling number of the second kind S(n, m) stands for the number of ways to partition a set of n things into m nonempty subsets. For example, there are seven ways to split a four-element set into two parts:

{1, 2, 3} U {4}, {1, 2, 4} U {3}, {1, 3, 4} U {2}, {2, 3, 4} U {1}

{1, 2} U {3, 4}, {1, 3} U {2, 4}, {1, 4} U {2, 3}.


There is a recurrence which allows to compute S(n, m) for all m and n.
S(0, 0) = 1; S(n, 0) = 0 for n > 0; S(0, m) = 0 for m > 0;

S(n, m) = m S(n - 1, m) + S(n - 1, m - 1), for n, m > 0.


Your task is much "easier". Given integers n and m satisfying 1 <= m <= n, compute the parity of S(n, m), i.e. S(n, m) mod 2.


Example
S(4, 2) mod 2 = 1.

 

Task

Write a program which for each data set:
reads two positive integers n and m,
computes S(n, m) mod 2,
writes the result.
Input

The first line of the input contains exactly one positive integer d equal to the number of data sets, 1 <= d <= 200. The data sets follow.

Line i + 1 contains the i-th data set - exactly two integers ni and mi separated by a single space, 1 <= mi <= ni <= 10^9.
Output

The output should consist of exactly d lines, one line for each data set. Line i, 1 <= i <= d, should contain 0 or 1, the value of S(ni, mi) mod 2.
Sample Input

1
4 2
Sample Output

1
 

代碼:

[cpp] 
#include<iostream> 
using namespace std; 
int f(int k) 

    int a=0; 
    while(k) 
    { 
      k=k/2; 
      a+=k; 
    } 
    return a; 

int main() 

    int t,n,m,z,w1,w2; 
    scanf("%d",&t); 
    while(t--) 
    { 
      scanf("%d%d",&n,&m); 
      z=n-(m+2)/2; 
      w1=(m-1)/2; 
      w2=z-w1; 
      if(f(z)==f(w1)+f(w2)) 
        printf("1%\n"); 
      else printf("0%\n"); 
    } 
    return 0; 

     
     

  1. 上一頁:
  2. 下一頁:
Copyright © 程式師世界 All Rights Reserved