程序師世界是廣大編程愛好者互助、分享、學習的平台,程序師世界有你更精彩!
首頁
編程語言
C語言|JAVA編程
Python編程
網頁編程
ASP編程|PHP編程
JSP編程
數據庫知識
MYSQL數據庫|SqlServer數據庫
Oracle數據庫|DB2數據庫
 程式師世界 >> 編程語言 >> C語言 >> C++ >> C++入門知識 >> poj 1733 Parity game(帶權並查集)

poj 1733 Parity game(帶權並查集)

編輯:C++入門知識

題目:
Description
Now and then you play the following game with your friend. Your friend writes down a sequence consisting of zeroes and ones. You choose a continuous subsequence (for example the subsequence from the third to the fifth digit inclusively) and ask him, whether this subsequence contains even or odd number of ones. Your friend answers your question and you can ask him about another subsequence and so on. Your task is to guess the entire sequence of numbers.

You suspect some of your friend's answers may not be correct and you want to convict him of falsehood. Thus you have decided to write a program to help you in this matter. The program will receive a series of your questions together with the answers you have received from your friend. The aim of this program is to find the first answer which is provably wrong, i.e. that there exists a sequence satisfying answers to all the previous questions, but no such sequence satisfies this answer.
Input
The first line of input contains one number, which is the length of the sequence of zeroes and ones. This length is less or equal to 1000000000. In the second line, there is one positive integer which is the number of questions asked and answers to them. The number of questions and answers is less or equal to 5000. The remaining lines specify questions and answers. Each line contains one question and the answer to this question: two integers (the position of the first and last digit in the chosen subsequence) and one word which is either `even' or `odd' (the answer, i.e. the parity of the number of ones in the chosen subsequence, where `even' means an even number of ones and `odd' means an odd number).
Output
There is only one line in output containing one integer X. Number X says that there exists a sequence of zeroes and ones satisfying first X parity conditions, but there exists none satisfying X+1 conditions. If there exists a sequence of zeroes and ones satisfying all the given conditions, then number X should be the number of all the questions asked.
Sample Input
10
5
1 2 even
3 4 odd
5 6 even
1 6 even
7 10 odd
Sample Output
3
Source
CEOI 1999


題目大意:
有長度為n的0和1組成的字符串, 然後問第L和R位置之間有奇數個1還是偶數個1.
根據這些回答, 判斷第幾個是錯誤(和之前有矛盾)的。


分析與總結:
做這題做到吐血,只能說太坑爹了。
題目給的數據量非常大,所以需要離散化, 這裡選擇了用哈希來做。
兩個區間如果相鄰,那麼奇數與奇數合並後就變成偶數, 偶數與偶數還是偶數,奇數與奇數還是奇數,那麼顯然可以用1代表奇數,0代表偶數, 用抑或操作符來計算合並之後是奇數還是偶數,這樣比直接計算距離更快些。

然後讓我吐血的地方是,一旦發現有矛盾了,要馬上跳出循環, 後面的那些數據不用去管他了,否則如果用continue就WA。

代碼:
[cpp]
#include<cstdio> 
#include<cstring> 
 
const int N = 6000; 
int f[N], rank[N], head[N],next[N],st[N],n, m, rear; 
 
inline void init(){ 
    rear = 0; 
    memset(head, -1, sizeof(head)); 
    for(int i=0; i<N; ++i) 
        f[i]=i, rank[i]=0; 

int insert_hash(int num){ 
    int h = num%N; 
    int u = head[h]; 
    while(u!=-1){ 
        if(st[u]==num) return u; 
        u = next[u]; 
    } 
    st[rear] = num; 
    next[rear] = head[h]; 
    head[h] = rear++; 
    return rear-1; 

int find(int x){ 
    if(x==f[x]) return x; 
    int fa=f[x]; 
    f[x] = find(f[x]); 
    rank[x] ^= rank[fa]; 
    return f[x]; 
}  
inline bool Union(int x, int y, int d){ 
    int ra=find(x), rb=find(y); 
    if(ra==rb){ 
        if(rank[x]^rank[y]!=d) return false; 
        return true; 
    } 
    f[ra] = rb; 
    rank[ra] = rank[x]^rank[y]^d; 
    return true; 

 
int main(){ 
    scanf("%d%d",&n,&m); 
    init(); 
    int ans=0, a,b,d; 
    char str[10]; 
    int i=0; 
    for(i=0; i<m; ++i){ 
        scanf("%d %d %s",&a,&b,str); 
        a = insert_hash(a-1); 
        b = insert_hash(b); 
        d = 0; 
        if(str[0]=='o') d=1; 
        if(!Union(a,b,d)){ 
            break; //直接跳出 
        } 
    } 
    printf("%d\n", i); 
    return 0; 

 

  1. 上一頁:
  2. 下一頁:
Copyright © 程式師世界 All Rights Reserved