程序師世界是廣大編程愛好者互助、分享、學習的平台,程序師世界有你更精彩!
首頁
編程語言
C語言|JAVA編程
Python編程
網頁編程
ASP編程|PHP編程
JSP編程
數據庫知識
MYSQL數據庫|SqlServer數據庫
Oracle數據庫|DB2數據庫
 程式師世界 >> 編程語言 >> C語言 >> C++ >> C++入門知識 >> poj 1703 Find them, Catch them(種類並查集)

poj 1703 Find them, Catch them(種類並查集)

編輯:C++入門知識

題目:
Find them, Catch them
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 22289   Accepted: 6648
Description
The police office in Tadu City decides to say ends to the chaos, as launch actions to root up the TWO gangs in the city, Gang Dragon and Gang Snake. However, the police first needs to identify which gang a criminal belongs to. The present question is, given two criminals; do they belong to a same clan? You must give your judgment based on incomplete information. (Since the gangsters are always acting secretly.)

Assume N (N <= 10^5) criminals are currently in Tadu City, numbered from 1 to N. And of course, at least one of them belongs to Gang Dragon, and the same for Gang Snake. You will be given M (M <= 10^5) messages in sequence, which are in the following two kinds:

1. D [a] [b]
where [a] and [b] are the numbers of two criminals, and they belong to different gangs.

2. A [a] [b]
where [a] and [b] are the numbers of two criminals. This requires you to decide whether a and b belong to a same gang.
Input
The first line of the input contains a single integer T (1 <= T <= 20), the number of test cases. Then T cases follow. Each test case begins with a line with two integers N and M, followed by M lines each containing one message as described above.
Output
For each message "A [a] [b]" in each case, your program should give the judgment based on the information got before. The answers might be one of "In the same gang.", "In different gangs." and "Not sure yet."
Sample Input
1
5 5
A 1 2
D 1 2
A 1 2
D 2 4
A 1 4
Sample Output
Not sure yet.
In different gangs.
In the same gang.
Source
POJ Monthly--2004.07.18


分析與總結:
做過一些的帶權並查集,再來做所謂的“種類並查集",發現好像就頓悟了。
種類並查集與帶權並查集實質上的差別並不大, 關鍵的區別就是種類並查集只是帶權並查集再弄個%取余操作而已,然後余數就表示他屬於哪個種類。
這題只有兩個種類,也就是只有0和1兩種, 對於兩個不同的種類,那麼之間的權值是相差1的,所以按照帶權並查集的方法做加上1,然後取余2即可。


代碼:
[cpp] 
#include<cstdio> 
 
const int N = 100005; 
int n, m, f[N], rank[N]; 
 
inline void init(){ 
    for(int i=1; i<=n; ++i) 
        f[i]=i,rank[i]=0; 

 
int find(int x){ 
    if(x==f[x])return f[x]; 
    int fa=f[x]; 
    f[x] = find(f[x]); 
    rank[x] = (rank[x]+rank[fa])&1; 
    return f[x]; 

 
inline bool Union(int x,int y){ 
    int a=find(x), b=find(y); 
    if(a==b) return false; 
    f[b] = a; 
    rank[b] = (rank[x]-rank[y]+1)&1; 

 
int main(){ 
    int T,a,b,fa,fb; 
    char ch; 
    scanf("%d",&T); 
    while(T--){ 
        scanf("%d%d%*c",&n,&m); 
        init(); 
        for(int i=0; i<m; ++i){ 
            scanf("%c%d%d%*c",&ch,&a,&b); 
            if(ch=='D'){ 
                Union(a,b); 
            } 
            else{ 
                fa = find(a), fb=find(b); 
                if(fa==fb){ 
                    if(rank[a]==rank[b]) puts("In the same gang."); 
                    else puts("In different gangs."); 
                } 
                else 
                    puts("Not sure yet."); 
            } 
        } 
    } 
    return 0; 

  1. 上一頁:
  2. 下一頁:
Copyright © 程式師世界 All Rights Reserved