程序師世界是廣大編程愛好者互助、分享、學習的平台,程序師世界有你更精彩!
首頁
編程語言
C語言|JAVA編程
Python編程
網頁編程
ASP編程|PHP編程
JSP編程
數據庫知識
MYSQL數據庫|SqlServer數據庫
Oracle數據庫|DB2數據庫
 程式師世界 >> 編程語言 >> C語言 >> C++ >> C++入門知識 >> POJ 字符串的全排列 水題也搞我 多種方法 DFS,STL,直接模擬

POJ 字符串的全排列 水題也搞我 多種方法 DFS,STL,直接模擬

編輯:C++入門知識

rders
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 8100   Accepted: 5048
Description

The stores manager has sorted all kinds of goods in an alphabetical order of their labels. All the kinds having labels starting with the same letter are stored in the same warehouse (i.e. in the same building) labelled with this letter. During the day the stores manager receives and books the orders of goods which are to be delivered from the store. Each order requires only one kind of goods. The stores manager processes the requests in the order of their booking.

You know in advance all the orders which will have to be processed by the stores manager today, but you do not know their booking order. Compute all possible ways of the visits of warehouses for the stores manager to settle all the demands piece after piece during the day.
Input

Input contains a single line with all labels of the requested goods (in random order). Each kind of goods is represented by the starting letter of its label. Only small letters of the English alphabet are used. The number of orders doesn't exceed 200.
Output

Output will contain all possible orderings in which the stores manager may visit his warehouses. Every warehouse is represented by a single small letter of the English alphabet -- the starting letter of the label of the goods. Each ordering of warehouses is written in the output file only once on a separate line and all the lines containing orderings have to be sorted in an alphabetical order (see the example). No output will exceed 2 megabytes.
Sample Input

bbjd
Sample Output

bbdj
bbjd
bdbj
bdjb
bjbd
bjdb
dbbj
dbjb
djbb
jbbd
jbdb
jdbb
Source

題意:

輸入字符串  輸出這個串的所有派生串   木有重復的哦     字符串長度最多200     都是字母小寫


我這樣寫  直接超時了   很是郁悶  放進map裡怎麼會超時那  我的想法是放進map可以防止重復   其實next_permutation 根本就不會產生重復串

他產生的是字典序改變的串(這個是字典序上升)
[cpp] 
#include<stdio.h> 
#include<string.h> 
#include<string> 
#include<algorithm> 
#include<iostream> 
#include<map> 
using namespace std; 
int main() 

    char s[300]; 
    int i,cnt; 
    map<string,int>mp; 
    map<string,int>::iterator it; 
    while(scanf("%s",s)!=EOF) 
    { 
        mp.clear(); 
        sort(s,s+strlen(s));//puts(s); 
        cnt=strlen(s); 
        do{ 
            mp[s]=1; 
        }while(next_permutation(s,s+cnt)); 
        for(it=mp.begin();it!=mp.end();it++) 
            cout<<it->first<<endl;//注意這裡哦    不要用printf  不支持 會有彈窗 
    } 
    return 0; 

後來改成這樣就過了  32ms
[cpp] 
#include<stdio.h> 
#include<string.h> 
#include<algorithm> 
using namespace std; 
int main() 

    char s[300]; 
    int i,cnt; 
    while(scanf("%s",s)!=EOF) 
    { 
        sort(s,s+strlen(s)); 
        cnt=strlen(s); 
        do{ 
               puts(s);  
        }while(next_permutation(s,s+cnt)); 
    } 
    return 0; 

下面是DFS方法  並且去重

[cpp] 
/*去重的方法是,如果當前的a的flag為1,即被使用了,而前一個a未被使用,則跳出。
用程序表示為flag[i]==1&&flag[i-1]==0&&s[i]==s[i-1]&&i>0     s中存放的是排序後的字符串*/ 
#include <stdio.h> 
#include <string.h> 
#include <stdlib.h> 
#include<algorithm> 
using namespace std; 
int len; 
int flag[201]; 
char str[201]; 
char res[201]; 
void dpoutput(int n) 

    int i; 
    if (n==len) 
    { 
        printf("%s\n", res); 
        return; 
    } 
    for (i=0;i<len;i++) 
    { 
        if (flag[i]||(i>0&&flag[i-1]==0&&str[i]==str[i-1])) 
            continue; 
        res[n]=str[i]; 
        flag[i] = 1; 
        dpoutput(n+1); 
        flag[i]=0; 
    } 

int main() 

    while (scanf("%s", str) != EOF) 
    { 
        len = strlen(str); 
        memset(flag, 0, sizeof(flag)); 
        sort(str,str+len); 
        dpoutput(0); 
    } 
    return 0; 

  1. 上一頁:
  2. 下一頁:
Copyright © 程式師世界 All Rights Reserved