程序師世界是廣大編程愛好者互助、分享、學習的平台,程序師世界有你更精彩!
首頁
編程語言
C語言|JAVA編程
Python編程
網頁編程
ASP編程|PHP編程
JSP編程
數據庫知識
MYSQL數據庫|SqlServer數據庫
Oracle數據庫|DB2數據庫
 程式師世界 >> 編程語言 >> C語言 >> C++ >> C++入門知識 >> hdu 4430 Yukaris Birthday 枚舉+二分

hdu 4430 Yukaris Birthday 枚舉+二分

編輯:C++入門知識

Problem Description
Today is Yukari's n-th birthday. Ran and Chen hold a celebration party for her. Now comes the most important part, birthday cake! But it's a big challenge for them to place n candles on the top of the cake. As Yukari has lived for such a long long time, though she herself insists that she is a 17-year-old girl.
To make the birthday cake look more beautiful, Ran and Chen decide to place them like r ≥ 1 concentric circles. They place ki candles equidistantly on the i-th circle, where k ≥ 2, 1 ≤ i ≤ r. And it's optional to place at most one candle at the center of the cake. In case that there are a lot of different pairs of r and k satisfying these restrictions, they want to minimize r × k. If there is still a tie, minimize r.

Input
There are about 10,000 test cases. Process to the end of file.
Each test consists of only an integer 18 ≤ n ≤ 1012.

Output
For each test case, output r and k.

Sample Input
18
111
1111

Sample Output
1 17
2 10
3 10

Source
2012 Asia ChangChun Regional Contest

枚舉r,然後用二分來求對應的k.
因為題目上k>=2,所以r肯定不會很大,二分就可以了。
需要注意的是二分時初始右邊界不能太大,不然會導致計算過程超出long long
還有就是提交時輸入輸出在zoj上要要用%lld,而hdu要用%I64d,不然會Wrong Answer

代碼:
[cpp] 
#include<stdio.h> 
#include<string.h> 
#include<stdlib.h> 
#include<math.h> 
long long powLL(long long a,int b){ 
    long long res=1; 
    for(int i=0;i<b;i++) 
        res*=a; 
    return res; 

int main(void){ 
    long long n,r,k; 
    while(scanf("%lld",&n)!=EOF){ 
        r=1; 
        k=n-1; 
        for(int i=2;i<=45;i++){ 
            long long ll,rr,mm; 
            ll=2; 
            rr=(long long)pow(n,1.0/i); 
            while(ll<=rr){ 
                mm=(long long)(ll+rr)/2; 
                long long ans=(mm-powLL(mm,i+1))/(1-mm); 
                if(ans==n||ans==n-1){ 
                    if(i*mm<r*k){ 
                        r=i; 
                        k=mm; 
                    } 
                    break; 
                } 
                else if(ans>n){ 
                    rr=mm-1; 
                } 
                else { 
                    ll=mm+1; 
                } 
            } 
        } 
        printf("%lld %lld\n",r,k); 
    } 
    return 0; 

  1. 上一頁:
  2. 下一頁:
Copyright © 程式師世界 All Rights Reserved