程序師世界是廣大編程愛好者互助、分享、學習的平台,程序師世界有你更精彩!
首頁
編程語言
C語言|JAVA編程
Python編程
網頁編程
ASP編程|PHP編程
JSP編程
數據庫知識
MYSQL數據庫|SqlServer數據庫
Oracle數據庫|DB2數據庫
 程式師世界 >> 編程語言 >> C語言 >> C++ >> C++入門知識 >> POJ 2524 Ubiquitous Religions

POJ 2524 Ubiquitous Religions

編輯:C++入門知識

Ubiquitous Religions
Time Limit: 5000MS   Memory Limit: 65536K
Total Submissions: 18323   Accepted: 8975
Description

There are so many different religions in the world today that it is difficult to keep track of them all. You are interested in finding out how many different religions students in your university believe in.

You know that there are n students in your university (0 < n <= 50000). It is infeasible for you to ask every student their religious beliefs. Furthermore, many students are not comfortable expressing their beliefs. One way to avoid these problems is to ask m (0 <= m <= n(n-1)/2) pairs of students and ask them whether they believe in the same religion (e.g. they may know if they both attend the same church). From this data, you may not know what each person believes in, but you can get an idea of the upper bound of how many different religions can be possibly represented on campus. You may assume that each student subscribes to at most one religion.
Input www.2cto.com

The input consists of a number of cases. Each case starts with a line specifying the integers n and m. The next m lines each consists of two integers i and j, specifying that students i and j believe in the same religion. The students are numbered 1 to n. The end of input is specified by a line in which n = m = 0.
Output

For each test case, print on a single line the case number (starting with 1) followed by the maximum number of different religions that the students in the university believe in.
Sample Input

10 9
1 2
1 3
1 4
1 5
1 6
1 7
1 8
1 9
1 10
10 4
2 3
4 5
4 8
5 8
0 0
Sample Output

Case 1: 1
Case 2: 7
Hint

Huge input, scanf is recommended.
Source

Alberta Collegiate Programming Contest 2003.10.18
考察點: 並查集
[cpp] 
#include <iostream> 
#include <string.h> 
#include <math.h> 
using namespace std; 
int a[50010]; 
int main() 

    void deal(int x,int y); 
    int i,j,n,m,s,t; 
    int x,y; 
    t=1; 
    while(cin>>n>>m) 
    { 
        if(!n&&!m) 
        { 
            break; 
        } 
        for(i=1;i<=n;i++) 
        { 
            a[i]=i; 
        } 
        for(i=1;i<=m;i++) 
        { 
            cin>>x>>y; 
            deal(x,y); 
        } 
        s=0; 
        for(i=1;i<=n;i++) 
        { 
            if(a[i]==i) 
            { 
                s+=1; 
            } 
        } 
        cout<<"Case "<<t<<":"<<" "<<s<<endl; 
        t++; 
    } 
    return 0; 

int find(int x) 

    int k1,k2; 
    k1=x; 
    while(k1!=a[k1]) 
    { 
        k1=a[k1]; 
    } 
    while(x!=a[x]) 
    { 
        k2=a[x]; 
        a[x]=k1; 
        x=k2; 
    } 
    return k1; 

void deal(int x,int y) 

    x=find(x); 
    y=find(y); 
    if(x!=y) 
    { 
        a[x]=y; 
    } 

  1. 上一頁:
  2. 下一頁:
Copyright © 程式師世界 All Rights Reserved