程序師世界是廣大編程愛好者互助、分享、學習的平台,程序師世界有你更精彩!
首頁
編程語言
C語言|JAVA編程
Python編程
網頁編程
ASP編程|PHP編程
JSP編程
數據庫知識
MYSQL數據庫|SqlServer數據庫
Oracle數據庫|DB2數據庫
 程式師世界 >> 編程語言 >> C語言 >> C++ >> C++入門知識 >> POJ Y2K Accounting Bug

POJ Y2K Accounting Bug

編輯:C++入門知識

Y2K Accounting Bug
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 7341   Accepted: 3630
Description

Accounting for Computer Machinists (ACM) has sufferred from the Y2K bug and lost some vital data for preparing annual report for MS Inc. www.2cto.com
All what they remember is that MS Inc. posted a surplus or a deficit each month of 1999 and each month when MS Inc. posted surplus, the amount of surplus was s and each month when MS Inc. posted deficit, the deficit was d. They do not remember which or how many months posted surplus or deficit. MS Inc., unlike other companies, posts their earnings for each consecutive 5 months during a year. ACM knows that each of these 8 postings reported a deficit but they do not know how much. The chief accountant is almost sure that MS Inc. was about to post surplus for the entire year of 1999. Almost but not quite.

Write a program, which decides whether MS Inc. suffered a deficit during 1999, or if a surplus for 1999 was possible, what is the maximum amount of surplus that they can post.
Input

Input is a sequence of lines, each containing two positive integers s and d.
Output

For each line of input, output one line containing either a single integer giving the amount of surplus for the entire year, or output Deficit if it is impossible.
Sample Input

59 237
375 743
200000 849694
2500000 8000000
Sample Output

116
28
300612
Deficit
Source

Waterloo local 2000.01.29
做這個題在找規律的時候找錯了,以為一個月賠本的的時候,一年中需要兩個月賠本。二個月賠本的時候,一年中要4個月賠本,於是就粗略的歸納出 2倍的關系,錯了好幾次,就用筆化了化,發現三個月的時候是滿足的但是四個月的時候就不滿足了。對於四個月一年中需要9個月賠本,改正之後交上去對了
[cpp] 
#include <iostream> 
#include <cstring> 
using namespace std; 
int main() 

    int i,j,n,m,s,t; 
    while(cin>>n>>m) 
    { 
        for(i=1;i<=4;i++) 
        { 
            if((i*m-(5-i)*n)>0) 
            { 
                break; 
            } 
        } 
        if(i==5) 
        { 
            cout<<"Deficit"<<endl; 
            continue; 
        } 
        if(i==1||i==2||i==3) 
        { 
            t=i*2; 
        }else if(i==4) 
        { 
            t=9; 
        } 
        s=(12-t)*n-(t)*m; 
        if(s>0) 
        { 
            cout<<s<<endl; 
        }else 
        { 
            cout<<"Deficit"<<endl; 
        } 
    } 
    return 0; 

  1. 上一頁:
  2. 下一頁:
Copyright © 程式師世界 All Rights Reserved