程序師世界是廣大編程愛好者互助、分享、學習的平台,程序師世界有你更精彩!
首頁
編程語言
C語言|JAVA編程
Python編程
網頁編程
ASP編程|PHP編程
JSP編程
數據庫知識
MYSQL數據庫|SqlServer數據庫
Oracle數據庫|DB2數據庫
 程式師世界 >> 編程語言 >> C語言 >> C++ >> C++入門知識 >> POJ 1273 Drainage Ditches

POJ 1273 Drainage Ditches

編輯:C++入門知識

Drainage Ditches
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 43977   Accepted: 16541
Description

Every time it rains on Farmer John's fields, a pond forms over Bessie's favorite clover patch. This means that the clover is covered by water for awhile and takes quite a long time to regrow. Thus, Farmer John has built a set of drainage ditches so that Bessie's clover patch is never covered in water. Instead, the water is drained to a nearby stream. Being an ace engineer, Farmer John has also installed regulators at the beginning of each ditch, so he can control at what rate water flows into that ditch.
Farmer John knows not only how many gallons of water each ditch can transport per minute but also the exact layout of the ditches, which feed out of the pond and into each other and stream in a potentially complex network.
Given all this information, determine the maximum rate at which water can be transported out of the pond and into the stream. For any given ditch, water flows in only one direction, but there might be a way that water can flow in a circle.
Input

The input includes several cases. For each case, the first line contains two space-separated integers, N (0 <= N <= 200) and M (2 <= M <= 200). N is the number of ditches that Farmer John has dug. M is the number of intersections points for those ditches. Intersection 1 is the pond. Intersection point M is the stream. Each of the following N lines contains three integers, Si, Ei, and Ci. Si and Ei (1 <= Si, Ei <= M) designate the intersections between which this ditch flows. Water will flow through this ditch from Si to Ei. Ci (0 <= Ci <= 10,000,000) is the maximum rate at which water will flow through the ditch.
Output

For each case, output a single integer, the maximum rate at which water may emptied from the pond.
Sample Input

5 4
1 2 40
1 4 20
2 4 20
2 3 30
3 4 10
Sample Output

50
Source

USACO 93
這題目最大流,我只想說最大流我也會了,雖然只是會了最簡單的EK算法,還是比較激動的
 #include <iostream>
#include <string.h>
using namespace std;
int a[300][300],pre[300];
int INF=0x7fffffff;
int sta,end,n,m;
int main()
{
    int E_K();
    int i,j,s,t;
    int x,y,val;
    while(cin>>n>>m)
    {
        memset(a,0,sizeof(a));
        sta=1; end=m;
        for(i=1;i<=n;i++)
        {
            cin>>x>>y>>val;
            a[x][y]+=val;
        }
        t=E_K();
        cout<<t<<endl;
    }
    return 0;
}
int bfs()
{
    int i,j,base,top,x,min1[1000];
    int queue[100000];
    base=top=0;
    queue[top++]=sta;
    memset(pre,-1,sizeof(pre));
    pre[sta]=0;
    min1[sta]=INF;
    while(base<top)
    {
        x=queue[base++];
        for(i=1;i<=m;i++)
        {
            if(i!=sta&&pre[i]==-1&&a[x][i])
            {
                pre[i]=x;
                min1[i]=min1[x]<a[x][i]? min1[x]:a[x][i];
                queue[top++]=i;
                if(i==end)
                {
                    break;
                }
            }
        }
        if(i!=m+1)
        {
            break;
        }
    }
    if(pre[end]==-1)
    {
        return -1;
    }
    return min1[end];
}
int E_K()
{
    int sum,i,j,k,step,t,pre_x,sum1;
    sum=0;
    while(1)
    {
        k=bfs();
        if(k==-1)
        {
            break;
        }
        sum+=k;
        for(t=end;t!=sta;t=pre[t])
        {
            pre_x=pre[t];
            a[pre_x][t]-=k;
            a[t][pre_x]+=k;
        }
    }
    return sum;
}

  1. 上一頁:
  2. 下一頁:
Copyright © 程式師世界 All Rights Reserved