程序師世界是廣大編程愛好者互助、分享、學習的平台,程序師世界有你更精彩!
首頁
編程語言
C語言|JAVA編程
Python編程
網頁編程
ASP編程|PHP編程
JSP編程
數據庫知識
MYSQL數據庫|SqlServer數據庫
Oracle數據庫|DB2數據庫
 程式師世界 >> 編程語言 >> C語言 >> C++ >> C++入門知識 >> HDU2560:Buildings

HDU2560:Buildings

編輯:C++入門知識

Problem Description
We divide the HZNU Campus into N*M grids. As you can see from the picture below, the green grids represent the buidings. Given the size of the HZNU Campus, and the color of each grid, you should count how many green grids in the N*M grids.

 

 

\


Input
Standard input will contain multiple test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
The first line of each test case contains two integers n and m(1<=n,m<=100), the size of the campus. Then follow n lines, each line containing m integers. The j-th integer in the i-th line is the color of that grid, 0 stands for white color, while 1 stands for green.


 


Output
Results should be directed to standard output. For each case, output an integers T, the total green grids in the N*M size campus.
 


Sample Input
2
2 2
1 1
0 0
3 3
1 0 1
0 0 1
1 1 0


Sample Output
2
5

 

題目那麼長,答案那麼水,我都無語了

就是統計方陣裡1的個數

 

[cpp]
#include <iostream>  
using namespace std; 
 
int main() 

    int t; 
    cin >> t; 
    while(t--) 
    { 
        int a,b,i,j,f,cnt = 0; 
        cin >> a >> b; 
        for(i = 0;i<a;i++) 
        { 
            for(j = 0;j<b;j++) 
            { 
                cin >> f; 
                if(f) 
                cnt++; 
            } 
        } 
        cout << cnt << endl; 
    } 
 
    return 0; 

#include <iostream>
using namespace std;

int main()
{
    int t;
    cin >> t;
    while(t--)
    {
        int a,b,i,j,f,cnt = 0;
        cin >> a >> b;
        for(i = 0;i<a;i++)
        {
            for(j = 0;j<b;j++)
            {
                cin >> f;
                if(f)
                cnt++;
            }
        }
        cout << cnt << endl;
    }

    return 0;
}


 

  1. 上一頁:
  2. 下一頁:
Copyright © 程式師世界 All Rights Reserved