程序師世界是廣大編程愛好者互助、分享、學習的平台,程序師世界有你更精彩!
首頁
編程語言
C語言|JAVA編程
Python編程
網頁編程
ASP編程|PHP編程
JSP編程
數據庫知識
MYSQL數據庫|SqlServer數據庫
Oracle數據庫|DB2數據庫
 程式師世界 >> 編程語言 >> C語言 >> C++ >> C++入門知識 >> poj1042

poj1042

編輯:C++入門知識

Gone Fishing
Time Limit: 2000MS Memory Limit: 32768K
Total Submissions: 25876 Accepted: 7615
Description


John is going on a fishing trip. He has h hours available (1 <= h <= 16), and there are n lakes in the area (2 <= n <= 25) all reachable along a single, one-way road. John starts at lake 1, but he can finish at any lake he wants. He can only travel from one lake to the next one, but he does not have to stop at any lake unless he wishes to. For each i = 1,...,n - 1, the number of 5-minute intervals it takes to travel from lake i to lake i + 1 is denoted ti (0 < ti <=192). For example, t3 = 4 means that it takes 20 minutes to travel from lake 3 to lake 4. To help plan his fishing trip, John has gathered some information about the lakes. For each lake i, the number of fish expected to be caught in the initial 5 minutes, denoted fi( fi >= 0 ), is known. Each 5 minutes of fishing decreases the number of fish expected to be caught in the next 5-minute interval by a constant rate of di (di >= 0). If the number of fish expected to be caught in an interval is less than or equal to di , there will be no more fish left in the lake in the next interval. To simplify the planning, John assumes that no one else will be fishing at the lakes to affect the number of fish he expects to catch.
Write a program to help John plan his fishing trip to maximize the number of fish expected to be caught. The number of minutes spent at each lake must be a multiple of 5.
Input


You will be given a number of cases in the input. Each case starts with a line containing n. This is followed by a line containing h. Next, there is a line of n integers specifying fi (1 <= i <=n), then a line of n integers di (1 <=i <=n), and finally, a line of n - 1 integers ti (1 <=i <=n - 1). Input is terminated by a case in which n = 0.
Output


For each test case, print the number of minutes spent at each lake, separated by commas, for the plan achieving the maximum number of fish expected to be caught (you should print the entire plan on one line even if it exceeds 80 characters). This is followed by a line containing the number of fish expected.
If multiple plans exist, choose the one that spends as long as possible at lake 1, even if no fish are expected to be caught in some intervals. If there is still a tie, choose the one that spends as long as possible at lake 2, and so on. Insert a blank line between cases.
Sample Input


2
1
10 1
2 5
2
4
4
10 15 20 17
0 3 4 3
1 2 3
4
4
10 15 50 30
0 3 4 3
1 2 3
0
Sample Output


45, 5
Number of fish expected: 31


240, 0, 0, 0
Number of fish expected: 480


115, 10, 50, 35

Number of fish expected: 724

分析:采用分治的方法,需要思索一番,找到分治的條件,即以逐步增加釣魚的湖數為分治條件,這樣就可以假設在任何時間,他可以移動到任何想去的湖,而移動的過程無需時間。只需在每個5分鐘的開始“瞬間移動”到當前5分鐘中能釣到最多的魚的湖中,且只釣5分鐘的魚。這樣逐步積累,等到時間耗盡時,就得到一次分治條件下的最大釣魚數。最後,分治完成,得到最大釣魚數。


代碼:


[cpp]
<PRE class=cpp name="code">#include<iostream> 
using namespace std; 
struct get_fish 

    int fish_num;//5分鐘可以釣到的魚數  
    int dis;//5分鐘釣魚數的減少量  
    int count;//記錄每個湖的釣魚時間  
}fish[26],fish1[26]; 
int get_max(get_fish a[],int n) 

    int max=1; 
    for(int i=2;i<=n;i++) 
    { 
        if(a[max].fish_num<a[i].fish_num) 
            max=i; 
    } 
    if(a[max].fish_num==0) 
        max=1; 
    //cout<<"m="<<max<<"\tmax="<<a[max].fish_num<<"\t";  
    return max; 

int cost[26];//第i個湖到第i+1個湖的時間  
int main() 

    int n;//n個湖  
    int h;//h個小時  
    int temp=0; 
    while(cin>>n&&n) 
    { 
        temp++; 
        cin>>h; 
        int time=h*12;//小時換算為若干個5分鐘  
        int i,sum_fish=0; 
        for(i=1;i<=n;i++) 
            cin>>fish[i].fish_num; 
        for(i=1;i<=n;i++) 
            cin>>fish[i].dis; 
        for(i=1;i<n;i++) 
            cin>>cost[i]; 
        for(int m=1;m<=n;m++)//釣完前m個湖  
        { 
            int temp_time=time; 
            for(i=1;i<=n;i++) 
            { 
                fish1[i].fish_num=fish[i].fish_num; 
                fish1[i].dis=fish[i].dis; 
                fish1[i].count=0; 
            } 
            //cout<<"m="<<m<<endl;  
            int temp_fish=0; 
            int fish_lake=0;//在哪個湖釣魚  
            for(i=1;i<m;i++)//總時間減去釣完前m個湖在路途中花費的時間  
                temp_time=temp_time-cost[i]; 
            //cout<<"time0="<<temp_time<<endl;  
            for(i=temp_time;i>0;i--)//時間逐步減少,直至時間耗盡  
            { 
                //cout<<"time="<<i<<"\t";  
                fish_lake=get_max(fish1,m);//得到當前最大釣魚數  
                temp_fish=temp_fish+fish1[fish_lake].fish_num; 
                //cout<<"temp_fish="<<temp_fish<<endl;  
                fish1[fish_lake].fish_num=fish1[fish_lake].fish_num-fish1[fish_lake].dis;//減少下個5分鐘釣的魚數  
                fish1[fish_lake].count++;//記錄釣魚次數  
                if(fish1[fish_lake].fish_num<0)//釣魚數不能為負數  
                    fish1[fish_lake].fish_num=0; 
            } 
            if(temp_fish>sum_fish) 
            { 
                for(i=1;i<=n;i++) 
                    fish[i].count=fish1[i].count; 
                sum_fish=temp_fish; 
            } 
            //cout<<"temp_fish="<<temp_fish<<endl;  
        } 
        for(i=1;i<=n-1;i++) 
        { 
                cout<<fish[i].count*5<<", "; 
        } 
        cout<<fish[n].count*5<<endl; 
        cout<<"Number of fish expected: "<<sum_fish<<endl<<endl; 
    } 
    return 0; 

</PRE><BR> 
<BR> 
<PRE></PRE> 

  1. 上一頁:
  2. 下一頁:
Copyright © 程式師世界 All Rights Reserved