程序師世界是廣大編程愛好者互助、分享、學習的平台,程序師世界有你更精彩!
首頁
編程語言
C語言|JAVA編程
Python編程
網頁編程
ASP編程|PHP編程
JSP編程
數據庫知識
MYSQL數據庫|SqlServer數據庫
Oracle數據庫|DB2數據庫
 程式師世界 >> 編程語言 >> C語言 >> C++ >> C++入門知識 >> hdu 1339 A Simple Task 數學題

hdu 1339 A Simple Task 數學題

編輯:C++入門知識

A Simple Task
                                                              Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Problem Description
Given a positive integer n and the odd integer o and the nonnegative integer p such that n = o2^p.


Example

For n = 24, o = 3 and p = 3.


Task

Write a program which for each data set:

reads a positive integer n,

computes the odd integer o and the nonnegative integer p such that n = o2^p,

writes the result.

 

Input
The first line of the input contains exactly one positive integer d equal to the number of data sets, 1 <= d <= 10. The data sets follow.

Each data set consists of exactly one line containing exactly one integer n, 1 <= n <= 10^6.

 

Output
The output should consists of exactly d lines, one line for each data set.

Line i, 1 <= i <= d, corresponds to the i-th input and should contain two integers o and p separated by a single space such that n = o2^p.

 

Sample Input
1
24

Sample Output
3 3
題意:輸入一個n,將n表示成一個奇數乘以2的p次方的積,輸出這個奇數和p。
解題思路:n對2取整,用一個計數變量記錄次數,直到余數為1時輸出n和次數。
[cpp]  #include<stdio.h>  
int main() 

    int n,t,p; 
    scanf("%d",&t); 
    while(t--) 
    { 
        scanf("%d",&n); 
        p=0; 
        while(n%2==0) //奇數除以2余數為1  
        { 
            p++; //記錄次數  
            n/=2; 
        } 
        printf("%d %d\n",n,p); 
    } 
    return 0; 

#include<stdio.h>
int main()
{
 int n,t,p;
 scanf("%d",&t);
 while(t--)
 {
  scanf("%d",&n);
  p=0;
  while(n%2==0) //奇數除以2余數為1
  {
   p++; //記錄次數
   n/=2;
  }
  printf("%d %d\n",n,p);
 }
 return 0;
}

  1. 上一頁:
  2. 下一頁:
Copyright © 程式師世界 All Rights Reserved