程序師世界是廣大編程愛好者互助、分享、學習的平台,程序師世界有你更精彩!
首頁
編程語言
C語言|JAVA編程
Python編程
網頁編程
ASP編程|PHP編程
JSP編程
數據庫知識
MYSQL數據庫|SqlServer數據庫
Oracle數據庫|DB2數據庫
 程式師世界 >> 編程語言 >> C語言 >> C++ >> C++入門知識 >> HDU1035:Robot Motion

HDU1035:Robot Motion

編輯:C++入門知識

Problem Description

\

A robot has been programmed to follow the instructions in its path. Instructions for the next direction the robot is to move are laid down in a grid. The possible instructions are

N north (up the page)
S south (down the page)
E east (to the right on the page)
W west (to the left on the page)

For example, suppose the robot starts on the north (top) side of Grid 1 and starts south (down). The path the robot follows is shown. The robot goes through 10 instructions in the grid before leaving the grid.

Compare what happens in Grid 2: the robot goes through 3 instructions only once, and then starts a loop through 8 instructions, and never exits.

You are to write a program that determines how long it takes a robot to get out of the grid or how the robot loops around.

 


Input
There will be one or more grids for robots to navigate. The data for each is in the following form. On the first line are three integers separated by blanks: the number of rows in the grid, the number of columns in the grid, and the number of the column in which the robot enters from the north. The possible entry columns are numbered starting with one at the left. Then come the rows of the direction instructions. Each grid will have at least one and at most 10 rows and columns of instructions. The lines of instructions contain only the characters N, S, E, or W with no blanks. The end of input is indicated by a row containing 0 0 0.

 


Output
For each grid in the input there is one line of output. Either the robot follows a certain number of instructions and exits the grid on any one the four sides or else the robot follows the instructions on a certain number of locations once, and then the instructions on some number of locations repeatedly. The sample input below corresponds to the two grids above and illustrates the two forms of output. The word "step" is always immediately followed by "(s)" whether or not the number before it is 1.

 


Sample Input
3 6 5
NEESWE
WWWESS
SNWWWW
4 5 1
SESWE
EESNW
NWEEN
EWSEN
0 0 


Sample Output
10 step(s) to exit
3 step(s) before a loop of 8 step(s)

 

簡單模擬,由於忘記給map初始化而WA了一次

 

[cpp] #include <stdio.h>  
#include <string.h>  
 
char map[20][20]; 
int mat[20][20]; 
 
int main() 

    int n,m,t,i,j,step; 
    while(~scanf("%d%d%d",&n,&m,&t)) 
    { 
        int flag = 0; 
        memset(mat,0,sizeof(mat)); 
        memset(map,'\0',sizeof(map)); 
        if(!n && !m) 
            break; 
        for(i = 0; i<n; i++) 
        { 
            scanf("%s",map[i]); 
        } 
        step = 1; 
        int x,y,loop = 0; 
        x = 0; 
        y = t-1; 
        while(1) 
        { 
            if(map[x][y] == 'N' && !mat[x][y]) 
            { 
                mat[x][y] = step; 
                x--; 
            } 
            else if(map[x][y] == 'S' && !mat[x][y]) 
            { 
                mat[x][y] = step; 
                x++; 
            } 
            else if(map[x][y] == 'E' && !mat[x][y]) 
            { 
                mat[x][y] = step; 
                y++; 
            } 
            else if(map[x][y] == 'W' && !mat[x][y]) 
            { 
                mat[x][y] = step; 
                y--; 
            } 
            else if(mat[x][y])//達到此處是達到了重復點,所以步數要-1  
            { 
                step--; 
                loop = step-mat[x][y]+1; 
                flag = 1; 
                break; 
            } 
            else if(x < 0 || y<0 || x >= n || y>=m)//達到此處時已出界,所以步數要-1  
            { 
                step--; 
                break; 
            } 
            step++; 
        } 
        if(flag) 
            printf("%d step(s) before a loop of %d step(s)\n",step-loop,loop); 
        else 
            printf("%d step(s) to exit\n",step); 
    } 
 
    return 0; 

  1. 上一頁:
  2. 下一頁:
Copyright © 程式師世界 All Rights Reserved