程序師世界是廣大編程愛好者互助、分享、學習的平台,程序師世界有你更精彩!
首頁
編程語言
C語言|JAVA編程
Python編程
網頁編程
ASP編程|PHP編程
JSP編程
數據庫知識
MYSQL數據庫|SqlServer數據庫
Oracle數據庫|DB2數據庫
 程式師世界 >> 編程語言 >> C語言 >> C++ >> C++入門知識 >> hdu 1515 Anagrams by Stack

hdu 1515 Anagrams by Stack

編輯:C++入門知識

Anagrams by Stack
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 843 Accepted Submission(s): 407

 

Problem Description
How can anagrams result from sequences of stack operations? There are two sequences of stack operators which can convert TROT to TORT:

[
i i i i o o o o
i o i i o o i o
]

where i stands for Push and o stands for Pop. Your program should, given pairs of words produce sequences of stack operations which convert the first word to the second.

A stack is a data storage and retrieval structure permitting two operations:

Push - to insert an item and
Pop - to retrieve the most recently pushed item
We will use the symbol i (in) for push and o (out) for pop operations for an initially empty stack of characters. Given an input word, some sequences of push and pop operations are valid in that every character of the word is both pushed and popped, and furthermore, no attempt is ever made to pop the empty stack. For example, if the word FOO is input, then the sequence:

i i o i o o is valid, but
i i o is not (it's too short), neither is
i i o o o i (there's an illegal pop of an empty stack)

Valid sequences yield rearrangements of the letters in an input word. For example, the input word FOO and the sequence i i o i o o produce the anagram OOF. So also would the sequence i i i o o o. You are to write a program to input pairs of words and output all the valid sequences of i and o which will produce the second member of each pair from the first.

 

Input
The input will consist of several lines of input. The first line of each pair of input lines is to be considered as a source word (which does not include the end-of-line character). The second line (again, not including the end-of-line character) of each pair is a target word. The end of input is marked by end of file.


Output
For each input pair, your program should produce a sorted list of valid sequences of i and o which produce the target word from the source word. Each list should be delimited by

[
]

and the sequences should be printed in "dictionary order". Within each sequence, each i and o is followed by a single space and each sequence is terminated by a new line.


Sample Input
madam
adamm
bahama
bahama
long
short
eric
rice

Sample Output
[
i i i i o o o i o o
i i i i o o o o i o
i i o i o i o i o o
i i o i o i o o i o
]
[
i o i i i o o i i o o o
i o i i i o o o i o i o
i o i o i o i i i o o o
i o i o i o i o i o i o
]
[
]
[
i i o i o i o o
]

Source
Zhejiang University Local Contest 2001


Recommend
LL
題目大意。模擬進出棧用給定序列得到目標序列。輸出滿足條件的方法。
[cpp]
#include <iostream>  
#include<stdio.h>  
#include<string.h>  
#include<stack>  
using namespace std; 
 
stack<char> sta;//用標准庫建立一個棧  
char s1[100],s2[100],way[200];//s1存給定序列s2存目標序列。way記錄操作  
int cnt; 
void print()//如果搜索到滿足條件的方法則輸出  

    int i; 
    for(i=0; i<cnt; i++) 
        printf("%c ",way[i]);//末尾空格處理了還錯了。暈!  
    printf("\n"); 

void dfs(int p1,int p2)//p1表示s1待入棧位置.p2表示s2待匹配位置  

    if(s2[p2]=='\0')//如果目標序列已完全匹配輸出答案返回  
    { 
        print(); 
        return; 
    } 
    char c; 
    if(s1[p1]!='\0')//如果s1還沒有完全進棧按題目要求字典順序(先進棧後出棧搜索)  
    { 
        c=s1[p1]; 
        sta.push(c); 
        way[cnt++]='i'; 
        dfs(p1+1,p2); 
        sta.pop(); 
        cnt--; 
    } 
    if(!sta.empty())//後出棧(如果棧不為空)開始沒判斷棧空,結果找了很久bug  
    { 
        c=sta.top(); 
        if(c==s2[p2])//注意該處剪枝  
        { 
            sta.pop(); 
            way[cnt++]='o'; 
            dfs(p1,p2+1); 
            cnt--; 
            sta.push(c); 
        } 
    } 

int main() 

    while(~scanf("%s%s",s1,s2)) 
    { 
        while(!sta.empty()) 
            sta.pop(); 
        cnt=0; 
        printf("[\n"); 
        dfs(0,0); 
        printf("]\n"); 
    } 
    return 0; 

#include <iostream>
#include<stdio.h>
#include<string.h>
#include<stack>
using namespace std;

stack<char> sta;//用標准庫建立一個棧
char s1[100],s2[100],way[200];//s1存給定序列s2存目標序列。way記錄操作
int cnt;
void print()//如果搜索到滿足條件的方法則輸出
{
    int i;
    for(i=0; i<cnt; i++)
        printf("%c ",way[i]);//末尾空格處理了還錯了。暈!
    printf("\n");
}
void dfs(int p1,int p2)//p1表示s1待入棧位置.p2表示s2待匹配位置
{
    if(s2[p2]=='\0')//如果目標序列已完全匹配輸出答案返回
    {
        print();
        return;
    }
    char c;
    if(s1[p1]!='\0')//如果s1還沒有完全進棧按題目要求字典順序(先進棧後出棧搜索)
    {
        c=s1[p1];
        sta.push(c);
        way[cnt++]='i';
        dfs(p1+1,p2);
        sta.pop();
        cnt--;
    }
    if(!sta.empty())//後出棧(如果棧不為空)開始沒判斷棧空,結果找了很久bug
    {
        c=sta.top();
        if(c==s2[p2])//注意該處剪枝
        {
            sta.pop();
            way[cnt++]='o';
            dfs(p1,p2+1);
            cnt--;
            sta.push(c);
        }
    }
}
int main()
{
    while(~scanf("%s%s",s1,s2))
    {
        while(!sta.empty())
            sta.pop();
        cnt=0;
        printf("[\n");
        dfs(0,0);
        printf("]\n");
    }
    return 0;
}


 

  1. 上一頁:
  2. 下一頁:
Copyright © 程式師世界 All Rights Reserved