程序師世界是廣大編程愛好者互助、分享、學習的平台,程序師世界有你更精彩!
首頁
編程語言
C語言|JAVA編程
Python編程
網頁編程
ASP編程|PHP編程
JSP編程
數據庫知識
MYSQL數據庫|SqlServer數據庫
Oracle數據庫|DB2數據庫
 程式師世界 >> 編程語言 >> C語言 >> C++ >> C++入門知識 >> HDU2660:Accepted Necklace(DFS)

HDU2660:Accepted Necklace(DFS)

編輯:C++入門知識

Problem Description
I have N precious stones, and plan to use K of them to make a necklace for my mother, but she won't accept a necklace which is too heavy. Given the value and the weight of each precious stone, please help me find out the most valuable necklace my mother will accept.

 


Input
The first line of input is the number of cases.
For each case, the first line contains two integers N (N <= 20), the total number of stones, and K (K <= N), the exact number of stones to make a necklace.
Then N lines follow, each containing two integers: a (a<=1000), representing the value of each precious stone, and b (b<=1000), its weight.
The last line of each case contains an integer W, the maximum weight my mother will accept, W <= 1000.

 


Output
For each case, output the highest possible value of the necklace.
 


Sample Input
1
2 1
1 1
1 1


Sample Output
1  題意:給出寶石的數目n,制成項鏈所需的寶石個數k,然後再給出每個寶石的價值與重量,還有母親會接受的最大價值,求出在最大價值范圍內,項鏈的價值盡可能大。思路:這一次用dfs做了,等掌握了二維費用背包之後再嘗試用背包去做
 [cpp]
#include <stdio.h>  
#include <string.h>  
  struct node  {    
 int v,w;  }p[50]; 
  int maxn,n,k,weight,vis[50];
   void dfs(int wei,int val,int step,int sum)
  {      if(sum == k || wei == weight)   
  {          if(maxn<val)          maxn = val; 
        return ;  
   }      for(int i = step;i<=n;i++)
     {          if(!vis[i] && sum+1<=k && wei+p[i].w<=weight) 
        {              vis[i] = 1;    
         dfs(wei+p[i].w,val+p[i].v,i+1,sum+1);  
           vis[i] = 0;          }    
 }      return ;  }    int
 main()  {      int t,i,j;   
  scanf("%d",&t);     
while(t--)      {      
   scanf("%d%d",&n,&k);     
    for(i = 1;i<=n;i++)     
    {              scanf("%d%d",&p[i].v,&p[i].w);  
           vis[i] = 0;          }      
   scanf("%d",&weight);   
      maxn = 0;  
       dfs(0,0,0,0);    
     printf("%d\n",maxn);   
  }        return 0;  } 

  1. 上一頁:
  2. 下一頁:
Copyright © 程式師世界 All Rights Reserved