程序師世界是廣大編程愛好者互助、分享、學習的平台,程序師世界有你更精彩!
首頁
編程語言
C語言|JAVA編程
Python編程
網頁編程
ASP編程|PHP編程
JSP編程
數據庫知識
MYSQL數據庫|SqlServer數據庫
Oracle數據庫|DB2數據庫
 程式師世界 >> 編程語言 >> C語言 >> C++ >> C++入門知識 >> HDU-1008 Elevator

HDU-1008 Elevator

編輯:C++入門知識

Problem Description
The highest building in our city has only one elevator. A request list is made up with N positive numbers. The numbers denote at which floors the elevator will stop, in specified order. It costs 6 seconds to move the elevator up one floor, and 4 seconds to move down one floor. The elevator will stay for 5 seconds at each stop.

For a given request list, you are to compute the total time spent to fulfill the requests on the list. The elevator is on the 0th floor at the beginning and does not have to return to the ground floor when the requests are fulfilled.

 

Input
There are multiple test cases. Each case contains a positive integer N, followed by N positive numbers. All the numbers in the input are less than 100. A test case with N = 0 denotes the end of input. This test case is not to be processed.

 

Output
Print the total time on a single line for each test case.

 

Sample Input
1 2
3 2 3 1
0

Sample Output
17
41

[html]  #include<iostream> 
using namespace std; 
 
int main() 

    int n; 
    int num[101]={0}; 
    int sum; 
    while(cin>>n,n) 
    { 
        sum=0; 
        for(int i=1;i<=n;i++) 
            cin>>num[i]; 
        for(int i=1;i<=n;i++) 
        { 
            if(num[i]>num[i-1]) 
                sum+=(num[i]-num[i-1])*6; 
            else sum+=(num[i-1]-num[i])*4; 
        } 
        cout<<sum+n*5<<endl; 
    } 
    return 0; 

#include<iostream>
using namespace std;

int main()
{
    int n;
    int num[101]={0};
    int sum;
    while(cin>>n,n)
    {
        sum=0;
        for(int i=1;i<=n;i++)
            cin>>num[i];
        for(int i=1;i<=n;i++)
        {
            if(num[i]>num[i-1])
                sum+=(num[i]-num[i-1])*6;
            else sum+=(num[i-1]-num[i])*4;
        }
        cout<<sum+n*5<<endl;
    }
    return 0;
}


 

  1. 上一頁:
  2. 下一頁:
Copyright © 程式師世界 All Rights Reserved